Computer Help forum

General discussion

Help mistake installing gpu, molex 4pin.

Hello,
I think I've made a schoolboy error, as I was fitting my new graphics card, i attached two "loose" molex 4 pin connectors together, the computer did not turn on, and still won't do now. Absolutely nothing happens when pressing on switch. Any suggestions on how to get it going again would be much appreciated.
Thanks
Technofob

Discussion is locked
You are posting a reply to: Help mistake installing gpu, molex 4pin.
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Help mistake installing gpu, molex 4pin.
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
If you're lucky

In reply to: Help mistake installing gpu, molex 4pin.

If you're lucky all you did was short out your power supply. If you're not so lucky, you made a feedback pulse that took out who knows how many different components on your computer.

To start with, go and get another power supply, because you've almost certainly fried the existing one if I'm understanding what you did correctly.

Collapse -
Unknown details

In reply to: Help mistake installing gpu, molex 4pin.

You haven't given any details or the gpu, system, you name it. Do you need a gpu power connection?

tada -----Willy Happy

Collapse -
thanks for your replies

In reply to: Unknown details

its a 8800 gt, it needed the power supply connecting to it, did that, then also connected the other end of the splitter to another 4 pin connector.
Its a 450w psu. LED is on on motherboard when plugged in, so it seems there is power there.

Popular Forums

icon
Computer Newbies 10,686 discussions
icon
Computer Help 54,365 discussions
icon
Laptops 21,181 discussions
icon
Networking & Wireless 16,313 discussions
icon
Phones 17,137 discussions
icon
Security 31,287 discussions
icon
TVs & Home Theaters 22,101 discussions
icon
Windows 7 8,164 discussions
icon
Windows 10 2,657 discussions

SMART HOME

This one tip will help you sleep better tonight

A few seconds are all you need to get a better night's rest.