Try this:

5. Deselect and then reselect the Display PDF In Browser preference

1.In Adobe Reader or Acrobat, choose Edit > Preferences.
2.Select Internet.
3.Deselect Display PDF In Browser, and then click OK.
4.Choose Edit > Preferences > Internet, select Display PDF In Browser, and then click OK.

http://kb2.adobe.com/cps/328/328233.html#main_Toggle Display PDF preference

This link should also be of some help.

Adobe Reader 9 or Adobe Acrobat 9 can not view PDF files in a Web Browser error and fix.
http://it.megocollector.com/?p=848

Tufenuf