Open Firefox, click on "Tools", select "Options", then click on the "Content" tab and CHECK the "Load images automatically" box. You might also need to install and enable Java and possibly Flash for any animated images.

Hope this helps.

Grif