General discussion

Help! Can download a program but can't run it anymore?!

Im using IE7 on Vista Premium. All of a sudden I can download a program but can't run it?!

Error message: C:Temporary Internet Files/Content.IE5/Y36V3498/program.exe

The directory name is invalid.


Please help!

Discussion is locked
Follow
Reply to: Help! Can download a program but can't run it anymore?!
PLEASE NOTE: Do not post advertisements, offensive materials, profanity, or personal attacks. Please remember to be considerate of other members. If you are new to the CNET Forums, please read our CNET Forums FAQ. All submitted content is subject to our Terms of Use.
Reporting: Help! Can download a program but can't run it anymore?!
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Comments
- Collapse -
Try...

When you download a program, you can choose the destination location - "Downloads", "Desktop"...or a folder you created, and run or install from there.

- Collapse -
Tried that...

Tried, and although I can see it on the desktop it still comes up with the same message!?

- Collapse -
Thoughts...

* C:\Temporary Internet Files\Content.IE5 is not a default directory under Vista, so it is curious where it originated from.

* Open Internet Explorer and go Tools->Delete Browsing History. Click the Delete All button for Temporary internet Files, confirm the deletion, and then try downloading/installing a program again.

* If the problem remains, see if you can browse to that location using Windows Explorer. (Through (My) Computer.) You may need to enable the viewing of hidden files/folders, as well as system files/folders. (Viewing options can be found by going Organize->Folder and Search Options->View.)

* If you can browse to that location, try using MoveOnBoot to delete the file.

* Back in Internet Explorer, go Options->Internet Options and click Settings under "Browsing options." Let us know the "current location" it lists.

* Have you tried double-clicking the downloaded application installer instead of simply clicking Run when Internet Explorer presents you with the option?

Let us know how it goes.
John

- Collapse -
Hi John!

Thanks for the reply.

Tried deleting internet history and re-installing program and running downloaded program but still the same error.

Tried searching for content.ie5 folder, but was not found even with system and hidden folders option enabled.

Tried Running the program even if I download it to the desktop and it still gives me the same message even though I can see it in front of me displaying the icon and size of file etc.

Location of internet temp files: C:/Users/Bagi Eger/Desktop/Bagi/Temporary Internet Files/

And thats it. Hope it helps and thanks for the interest!
Vista's making me go grey...

- Collapse -
Same problem on D drive now

Just noticed that I get the same error message on my D drive too when I try to run off disc:

D:/

Directory name is invalid


Whats going on?

Heeeeeelp please?

- Collapse -
Some additional thoughts...

* Scan with antivirus software (ensure compatibility with Vista before beginning) and verify that you are not infected.

* Press Windows + R to display the run prompt and then enter sfc scannow (with the space) and press Enter. Windows will then go through the process of scanning your computer and verifying the correctness of each system file.

* Try booting in Safe Mode (press F8 during boot) and see if the problem remains.

* Perform a System Restore back to a time when it last worked properly, if it ever did in the first place.

Let us know how it goes.
John

- Collapse -
Still no luck

Have tried all the above now.

System restore doesn't restore and only goes back a few days.

Booting in safe mode still the same problem.

But I can download and play videos, see pics etc. it seems to not like exe. files.

- Collapse -
Clever me

I had to turn off UAC. Now I can run the .exe files.

Pat on the back for me.

- Collapse -
Good job!

The error message it spit out did not point in the direction of UAC, so I never thought of it. I'm curious as to why it glitched like that, but am glad you got it sorted out.

John

CNET Forums