did you try the other F keys? like F2 f3 ...

if you get to grub you can try booting into older kernel versions or edit the grub start command with the "e" key and turn on verbose (shut off quiet) and see if you can see your problem.