Desktops forum

General discussion

Hard Drive Problem

by jandss / September 27, 2008 5:54 AM PDT

I'm trying to instal a new IDE drive in my computer. The idea was to replace an 80GB drive with a 320GB Maxtor Diamond Max 21 drive (both IDE).

On installation the computer failed to see either drive and now will see one or the other but only as a slave drive. Seeing only one drive is not a problem, I'm quite happy to just have the one HDD, I just thought I might as well use the old one as I had it.

I've set the jumpers on the drives to CS and used the correct connector on the IDE cable (both as one drive and also with both connected up). I've tried connecting using a different cable. I've then tried installing a single drive setting the jumpers to the Master position and tried both connectors on the cable.

Whatever I've tried, the computer either sees no drive or a slave drive. This is using the primary IDE connection. The secondary is set up with a DVD/ROM and a DVD/RW which have been working ok. They show as one master and one slave.

Motherboard: Asus K8V SE Deluxe

Any help getting this sorted will be greatly appreciated.

jandss

Discussion is locked
You are posting a reply to: Hard Drive Problem
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Hard Drive Problem
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
Is the BIOS up to date?
by R. Proffitt Forum moderator / September 27, 2008 6:00 AM PDT
In reply to: Hard Drive Problem

Did you try loading the BIOS defaults?

And let's be clear that we don't bother with Windows until the BIOS sees it.

Collapse -
Yes
by jandss / September 27, 2008 6:10 AM PDT

I loaded the BIOS default settings but it didn't fix the problem - still showing the drive as primary slave.
jandss

Collapse -
Since this board has SATA ports.
by R. Proffitt Forum moderator / September 27, 2008 6:35 AM PDT
In reply to: Hard Drive Problem
Collapse -
Disabled the
by jandss / September 27, 2008 8:52 PM PDT

OnChip SATA Bootrom and Onboard Promise Controller after having reset to default settings. The cable is connected to the drive using the end connector (black) and the jumpers are set to CS in accordance with the picture on the drive and the Maxtor website. The computer is still registering the drive as Primary IDE Slave.

Collapse -
I forget one thing.
by R. Proffitt Forum moderator / September 27, 2008 10:31 PM PDT
In reply to: Disabled the

Are you using the 80 conductor cables?

Since you are not using SATA devices I'd disable that and the RAID in the bios to avoid that issue about IDE emulation or where some of these boards (badly documented!) reserve the Primary IDE Master to the IDE or SATA RAID port. Why it does that is a very long explanation which I'll not be doing in this small space.
Bob

Collapse -
Definitely using 80 cable.
by jandss / September 28, 2008 4:54 AM PDT
In reply to: I forget one thing.

Also I've just tried a different cable again to be on the safe side.
However, I've just found that the system time has zeroed. If the CMOS battery needs changing would that cause this problem?

Collapse -
CMOS battery?
by R. Proffitt Forum moderator / September 28, 2008 5:46 AM PDT

It won't help having it fail during this.

Collapse -
Battery now replaced.
by jandss / September 29, 2008 2:00 AM PDT
In reply to: CMOS battery?

I rebooted, reset the BIOS as per above postings and drive still shows as Pri Slave.

Collapse -
Then
by R. Proffitt Forum moderator / September 29, 2008 3:31 AM PDT
In reply to: Battery now replaced.

The board has failed or we still got the cable and jumpers wrong. Here's how I test. I put the cable on the second IDE port and see if it goes master. If so, bad board. If not, I did the cable, jumper or drive wrong.
Bob

Collapse -
Yippee!!!
by jandss / September 29, 2008 7:58 PM PDT
In reply to: Then

I followed your suggestion for checking that the problem didn't lie with the board so after that I went back to square one. Redid all the jumpers on both the old and new drives and it now sees both correctly.

Many thanks for your help. It may have been a stupid mistake on my part, but at least it showed up the failing CMOS battery when the computer was opened up.

Sue

Collapse -
Thanks for the report.
by R. Proffitt Forum moderator / September 29, 2008 11:33 PM PDT
In reply to: Yippee!!!

Sometimes we have to step back and make another run at these things.

Popular Forums
icon
Computer Newbies 10,686 discussions
icon
Computer Help 54,365 discussions
icon
Laptops 21,181 discussions
icon
Networking & Wireless 16,313 discussions
icon
Phones 17,137 discussions
icon
Security 31,287 discussions
icon
TVs & Home Theaters 22,101 discussions
icon
Windows 7 8,164 discussions
icon
Windows 10 2,657 discussions

CNET FORUMS TOP DISCUSSION

Help, my PC with Windows 10 won't shut down properly

Since upgrading to Windows 10 my computer won't shut down properly. I use the menu button shutdown and the screen goes blank, but the system does not fully shut down. The only way to get it to shut down is to hold the physical power button down till it shuts down. Any suggestions?