Browsers, E-mail, & Web Apps forum

General discussion

Google regional settings issues.

by kasua4522 / October 5, 2010 1:51 AM PDT

I am a united states soldier stationed in germany, i have a pc bought in the united states and the english version of mozilla firefox installed on my computer however when i type in url's ending in .com most of them are redirected to .de, and when i search for items using any type of search engine the results all turn up in german. i have translator add-on installed for firefox and, while useful it is very innacurate. so i guess my question is how can i change the locale or region settings to eliminate this issue. thank you!

Discussion is locked
You are posting a reply to: Google regional settings issues.
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Google regional settings issues.
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
You've asked a very interesting question
by MDFlax / October 5, 2010 9:34 PM PDT

and a difficult one I fear. I had, (sneakily), tracked your discussion hoping some tech wizard would reply with an easy answer so I could try it out myself, but day 2 and no replies, so I have tried to do a bit of research myself.

I used Google itself with the term How to change Google regional settings. There may be better terms to search for.

Google is geared to supply advertising based on your IP address. It recognises your IP location, (Germany), and so targets ads for Germany. Advertising is Google's business and so it seems to me that search results are listed according to the IP criteria, in your case, German.

Try this, if you haven't already done so. Google main page, then "Language Tools" to the right of the search box. In the new page, look for the "Specify Language" option and select. Then choose English as the language. If there is a "Save Preferences" button, click that. If that helps, you may be able to disable the Firefox translator add-on.

I have just seen, scrolled down on that page, a list of nations flags and "Visit Google's Site in Your Local Domain". However, for the life of me I cannot find the USofA flag. I can see my own, (UK), but not US. That might be worth a try, possibly using the UK flag option.

There's an involved discussion about this here;
http://forums.searchenginewatch.com/archive/index.php/t-9468.html

You might find that useful, but I would guess that, at the end of the day, you may be limited to Google searching based on your location.

Not good, but I hope it helps.

Mark

Collapse -
this worked for me
by jonah jones / October 6, 2010 1:00 PM PDT

i live in Israel and here it always defaults to google.co.il

my work around was to click on a link in an email

try clicking this google

jonah

if you're anywhere near Munich or Augsburg, have a beer for me Happy

,.

Collapse -
Maybe it's late but I reply for future reference.
by ElStellino / January 4, 2012 7:41 PM PST

This is my experience: I always had problem with all the google searches I was performing since I moved to Lithuania.
Not my researches launched from my homepage which is google.co.uk, but all the researches I do right clicking an highlighted word and selecting "Search with google" all the result were in Lithuanian, which I don't speak at all.
Today I researched online and found very little. I decided then to work it out by myself because I am here since June 2011 and still at today's date my quick searches were displayed in Lithuanian.

Well, not any more.
If you go here
http://www.google.com/language_tools
you can set up your language under the fourth paragraph.

In here then you should see English, if not change for it.
http://www.google.com/preferences?hl=en

Popular Forums
icon
Computer Newbies 10,686 discussions
icon
Computer Help 54,365 discussions
icon
Laptops 21,181 discussions
icon
Networking & Wireless 16,313 discussions
icon
Phones 17,137 discussions
icon
Security 31,287 discussions
icon
TVs & Home Theaters 22,101 discussions
icon
Windows 7 8,164 discussions
icon
Windows 10 2,657 discussions

CNET FORUMS TOP DISCUSSION

Help, my PC with Windows 10 won't shut down properly

Since upgrading to Windows 10 my computer won't shut down properly. I use the menu button shutdown and the screen goes blank, but the system does not fully shut down. The only way to get it to shut down is to hold the physical power button down till it shuts down. Any suggestions?