Browsers, E-mail, & Web Apps forum

Question

Google.ca links won't open in Firefox 10

by MelH / February 9, 2012 4:56 AM PST

The google.ca site opens fine and responds to the initial search query, but the links to each article found do not open when click. It's as if they are not hyperlinked. No visible evidence of the browser searching for that clicked link at all. Just sits there and does nothing.
If you right click the link and open in IE window, that works, as does searching Google.ca in IE alone.

I've run AVG and Mbam with no negative results.
My Hosts file does not contain any link to google.
I've shut down all add-ons in Firefox with no results.
I disabled AdBlock in Firefox with no results.
I rebooted the system just for luck but didn't have any.

Has anyone else experienced this?
Using Windows XP Pro.

Discussion is locked
You are posting a reply to: Google.ca links won't open in Firefox 10
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Google.ca links won't open in Firefox 10
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.

All Answers

Collapse -
Answer
A strange one
by MarkFlax Forum moderator / February 9, 2012 8:40 PM PST

You've done everything I would have suggested, so all that's left as a quick test is to try Firefox's Safe Mode.

Have a look at http://support.mozilla.org/en-US/kb/Safe%20Mode for the new methods to do that. Then test Google's links to see if they now work.

Mark

Collapse -
It seems to have fixed itself...
by MelH / February 9, 2012 9:21 PM PST
In reply to: A strange one

Thanks, Mark, I had done the safe mode thing as well. Looks like this was more on Google's side than mine.
I have read other comments across the net about this incident, which happened to me only yesterday and had righted itself by the early evening. Just another glitch to contend with, I guess.

Collapse -
That's great
by MarkFlax Forum moderator / February 10, 2012 8:40 PM PST

and thanks for reporting back.

It does happen on occasion. I remember some years ago that someone at Google changed a flag code in error and that caused 'all links' to display the "This web site may be dangerous" message for all users.

Mark

Collapse -
Answer
Having same problem
by RonHK / February 14, 2012 10:57 AM PST

Using XP Media center with all updates installed. Google is totally dead to any link clicks from Firefox. Links work fine from other browsers and from Bing within Firefox. If I can't find a fix will have to abandon Firefox. Have tried everything, including a complete delete and reinstall.

RonHK

Collapse -
How did you get on
by MarkFlax Forum moderator / February 14, 2012 7:59 PM PST
In reply to: Having same problem

with the quick test I offered to the original poster?

Mark

Popular Forums
icon
Computer Newbies 10,686 discussions
icon
Computer Help 54,365 discussions
icon
Laptops 21,181 discussions
icon
Networking & Wireless 16,313 discussions
icon
Phones 17,137 discussions
icon
Security 31,287 discussions
icon
TVs & Home Theaters 22,101 discussions
icon
Windows 7 8,164 discussions
icon
Windows 10 2,657 discussions

CNET FORUMS TOP DISCUSSION

Help, my PC with Windows 10 won't shut down properly

Since upgrading to Windows 10 my computer won't shut down properly. I use the menu button shutdown and the screen goes blank, but the system does not fully shut down. The only way to get it to shut down is to hold the physical power button down till it shuts down. Any suggestions?