Fix my problem with some help. Just in case anyone else stumbles across this and needs the answer heres how I did it:

-Connected the boxes back to back w/ a crossover cable (basic ethernet cable works fine)

-Give them IP's in their own subnet;

Ubuntu: 10.10.1.1 / 255.255.255.252 (System -> Preferences -> Network Connection -> Wired -> auto etho0(or something close) -> IPv4 Settings)

Windows: 10.10.1.2 255.255.255.252 (Networking and sharing center -> Manage network connections -> Local Area Connection -> Properties -> IPv4)

-Enable IP forwarding on the Ubuntu box (sysctl -w net.ipv4.ip_forward=1)

-On the Windows box, set the default gateway to the Ubuntu machine (10.10.1.1)(same way as changing the IP and subnet)

-On your wireless router, set a static route: 10.10.1.0 / 255.255.255.252 -> nexthop:[ip for ubuntu on your local net]