Peripherals forum

General discussion

Generic IEEE 1284.4 printing support - PROBLEM

by mg6782 / January 9, 2006 7:20 AM PST


I've been trying to reinstall my HP Photosmart printer after a reinstall of XP but everytime I load the drivers, i get a "found new hardware" message for Generic IEEE 1284.4 printing support. Each time it cannot find the drivers in any location and I can't stop the found new hardware message popping up everytime i start windows etc.

Few more bits of info:
- I am able to print through the printer although printing is VERY slow.
- I have other USB devices connected and these work fine.
- I'm running Win XP Home, with SP1 and SP2 (as I understood it USB support was included in SP1 but I already have this installed).

Grateful for any help and ideas!!


Discussion is locked
You are posting a reply to: Generic IEEE 1284.4 printing support - PROBLEM
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Generic IEEE 1284.4 printing support - PROBLEM
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
Solution to PhotoSmart 100 "Generic IEEE 1284.4" Problem!!
by lorien5 / August 31, 2006 11:14 PM PDT

Matt -

I have an HP PhotoSmart 100 printer that I have been trying to link up to a laptop running Windows XP. I also got the "Generic IEEE 1284.4 Printing Support" error message when trying to add the printer and could find absolutely NO HELPFUL SUGGESTIONS ON THE NET ANYWHERE!! (Lots of useless suggestions and simply nowhere to download the IEEE 1284.4 driver. Yet another of these 'black hole' computer problems that makes you think that you are the only person in the world experiencing what should be a common problem!! Very frustrating!!

Well, here's how I fixed the problem:

1) Go to and select your particular HP PhotoSmart device.

2) Download all of the software for your particular PhotoSmart device and install on your computre (requires restart).

3) Connect your PhotoSmart device to your computer and try to add the printer using the Printer Wizard dialog boxes.

4) If you should get the message saying that no "Generic IEEE 1284.4 Printing Support" and if the Wizard cannot find the software online (which is what happened in my case), specify the location of the driver by browsing to the location of your newly downloaded and installed PhotoSmart software. A folder with the name "photosmart" should have been installed in c:\temp. Browse to this folder and select. Then let the Wizard search the "photosmart" folder for the IEEE 1284.4 driver. You will be pleased to see the Wizard finally recognize "PhotoSmart" software and then a cascade of confirmations and further software installations follow with the PhotoSmart software completing its setup on your computer!

5) Your PhotoSmart device will now be recognized and you can begin printing to the device.

Hope this is helpful to everyone.


Collapse -
by dentalgeek / March 17, 2009 10:51 AM PDT

I had the same problem with the "generic ieee 1284.4 printing support" error. My computer would not recognize the USB as a printer, but it was a simple matter of downloading the correct driver.

Thanks for the helpful response!

Collapse -
Thanks!!! re PhotoSmart "Generic IEEE 1284.4" SOLUTION!
by SteveTeo2 / August 11, 2009 6:59 AM PDT

Thank you so much Lorien5!!!!

I was struggling with the same problem Matt described in the forum, and when I tried your recommendation, it worked immediately. I went from scratching my head for 10 minutes to immediate gratification and printing!

For that, I joined CNET and will participate as often as I can. This is a great resource, and I really appreciate your help, Lorien5!

Steve T.

Collapse -
Solved - PhotoSmart 100 "Generic IEEE 1284.4" Problem!! -
by garris1 / November 14, 2009 1:01 AM PST


It's been over 3 years since you posted your solution, but it's still valuable and useful. And a problem solver.

Without really knowing what I was doing, I had done the first three steps, but didn't know the details given in the 4th step. That made all of the difference. And it solved the problem I'd been struggling with for weeks.

BTW, I running Win XP Home w/SP3 in a VMware Fusion virtual machine on a MacBook Pro.

Thanks. And thanks.
Kenn Garrison

Collapse -
my search is over
by jimsmith / January 6, 2011 10:49 AM PST

I know that this is an old post but it ended me days of searching for the solution for this problem. I am not sure why this worked but it did. thanks you 1000X

Popular Forums
Computer Newbies 10,686 discussions
Computer Help 54,365 discussions
Laptops 21,181 discussions
Networking & Wireless 16,313 discussions
Phones 17,137 discussions
Security 31,287 discussions
TVs & Home Theaters 22,101 discussions
Windows 7 8,164 discussions
Windows 10 2,657 discussions


Help, my PC with Windows 10 won't shut down properly

Since upgrading to Windows 10 my computer won't shut down properly. I use the menu button shutdown and the screen goes blank, but the system does not fully shut down. The only way to get it to shut down is to hold the physical power button down till it shuts down. Any suggestions?