Peripherals forum

General discussion

Games will not recognise DVD when trying to run

by photodom2000 / November 4, 2005 9:09 PM PST

All of my games programmes have stopped recognising my DVD player when I try too run the game. I can install games from the DVD and see what is on each disk using explorer, but everytime I try and run the game I get a message saying I need to put the orginal DVD in the drive or that it can't find the DVD. My DVD is an NEC ND 3520A. I am running a fully up to date version of XP Home. I can still write CD's and DVD's using the drive. My gut feeling is that this is a software problem. Any help would be appreciated.

Thanks

Discussion is locked
You are posting a reply to: Games will not recognise DVD when trying to run
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Games will not recognise DVD when trying to run
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
(NT) (NT) Has it ever worked???
by jackintucson / November 5, 2005 2:22 AM PST
Collapse -
Yes - they used to work but don't know why they stopped.
by photodom2000 / November 5, 2005 3:01 AM PST

I've tried to enable DMA but for some reason this option isn't available to me in Hradware Device Manager.

Popular Forums
icon
Computer Newbies 10,686 discussions
icon
Computer Help 54,365 discussions
icon
Laptops 21,181 discussions
icon
Networking & Wireless 16,313 discussions
icon
Phones 17,137 discussions
icon
Security 31,287 discussions
icon
TVs & Home Theaters 22,101 discussions
icon
Windows 7 8,164 discussions
icon
Windows 10 2,657 discussions

CNET FORUMS TOP DISCUSSION

Help, my PC with Windows 10 won't shut down properly

Since upgrading to Windows 10 my computer won't shut down properly. I use the menu button shutdown and the screen goes blank, but the system does not fully shut down. The only way to get it to shut down is to hold the physical power button down till it shuts down. Any suggestions?