Question

Game won't start off a disk image, but works with the disc

Oct 17, 2016 5:13PM PDT

If I start the game (Prince of Persia: Warrior Within) with the DVD in the physical (external) drive, all works well. However, if I attempt to do so with only the disc image mounted, I get the "The game ended unexpectedly" error.

I'm on Windows 10 HP, I have tried using its native virtual machine as well as the Daemon Tools' one. I have tried remaking the image file and also installing the game from the image, rather than the physical disc. I have tried various compatibility settings.

None of it was successful, the problem persists, and clearly the ONLY difference between when it works and when not is whether I use the physical, or the virtual drive.

Strange indeed - I thought the application shouldn't be able to distinguish between the two cases.

Discussion is locked

Follow
Reply to: Game won't start off a disk image, but works with the disc
PLEASE NOTE: Do not post advertisements, offensive materials, profanity, or personal attacks. Please remember to be considerate of other members. If you are new to the CNET Forums, please read our CNET Forums FAQ. All submitted content is subject to our Terms of Use.
Reporting: Game won't start off a disk image, but works with the disc
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Comments
- Collapse -
Answer
checked for second session on disc?
Oct 17, 2016 5:34PM PDT
- Collapse -
I use Daemon Tools
Oct 17, 2016 10:21PM PDT

- as mentioned in the question. I reckon it ought not be so stupid as to not be able to do multi-session, but I will give something else try.

Thanks for your suggestion.

- Collapse -
Update
Oct 17, 2016 10:37PM PDT

Now that's interesting...

If I mount the image via Daemon Tools, it throws the "ended unexpectedly error".

When I try it using the Clone Drive, it says "Insert the correct CD" instead...

Either way, the game seems not to count a virtual disc as a proper one.

- Collapse -
that's an easy one
Oct 18, 2016 10:17AM PDT
"When I try it using the Clone Drive, it says "Insert the correct CD" instead..."

It just told you the answer. It's looking for the CD identifier or volume name. I don't know if Clone CD does it, but you can try giving the ISO the same volume name used by the CD. If that doesn't work, then you are into something deeper and I can't help you with that.
- Collapse -
Answer
This is how it should be.
Oct 17, 2016 6:12PM PDT

That game uses the disc as it's copy protection. So nothing is wrong here. It's working as it was designed to.

- Collapse -
a single disc is fine
Oct 17, 2016 6:21PM PDT
- Collapse -
I say it's old school.
Oct 17, 2016 6:41PM PDT

I think I haven't loaded up a CD/DVD game in about a decade.

- Collapse -
I don't think so
Oct 17, 2016 10:17PM PDT

My intuition is that the game should NOT be able to tell the difference between a virtual and a physical drive.

For the record, if you're right, I consider this quite a despicable practice by the publishers - I do own the game, I just don't have a physical DVD drive on my laptop, and it's bothersome to have to plug in the external one all the time.

- Collapse -
The thing is
Oct 17, 2016 10:33PM PDT

We can't discuss breaking copy protection. You agreed to that when you joined. I did a little google to see why this would fail and it was pretty clear it's not supposed to work.

Try to think about other members when asking for cracks. It's an area that we can't get into and folk may inadvertently help you "jack this car."

Post was last edited on October 17, 2016 10:37 PM PDT

- Collapse -
This was not the case
Oct 17, 2016 11:01PM PDT

It appears to have been due to .iso unable to do multi-session.

Otherwise, I doubt a game on its own would be able to tell a virtual machine from a physical one - how would that be possible?

- Collapse -
It appears its solved.
Oct 18, 2016 8:52AM PDT

I can't guess if you googled how and found the noCD cracks to make it happen.

Have fun in the game.

- Collapse -
Seriously?
Oct 18, 2016 5:37PM PDT

I explicitly stated what the problem was and did not mention a no-CD crack one single time.

- Collapse -
All the solves I read.
Oct 18, 2016 5:39PM PDT

Involved that crack. Sorry if google offends you here.

- Collapse -
I haven't play game for a long long time but...
Oct 18, 2016 11:12AM PDT

I remember that's how it was in the old day (copy protection). We use image because it's faster than the disc.

- Collapse -
Answer
Resolved!
Oct 17, 2016 10:56PM PDT

The problem was an intrinsic one pertaining to ISO files - apparently, they don't support multi-session.

A viable solution is to use a different type of image file - I used .mds created and mounted with Daemon Tools, and it works!

Thanks for all the replies.

P.S. I could have sworn that it worked off an .iso back with Windows 7, but I may well be wrong.

- Collapse -
good for you!
Oct 18, 2016 10:19AM PDT

enjoy the increased speed the hard drive provides. Also not having to swap discs if it's more than one.

CNET Forums

Forum Info