Windows Legacy OS forum

General discussion

FTP problems - Can't open data connection for LIST

by JudySmith / November 4, 2003 3:29 PM PST

Since my new Dell/XP system, Leech FTP isn't connecting (I had no such problems on my old Compaq/Win98). When I referenced google, I came across a post by someone on annoyances.org who also had FTP problems but when they lowered their ZoneAlarm security to Medium (from High) they were enabled to connect.

So I'd tried that, and it seemed to be resolved. But now I'm getting error messages again as follows:

Can't open data connection for LIST
Could not retrieve directory listing for "/"


I even tried turning the security to the lowest - meaning no security at all. Yet still couldn't connect.
Also note that in my ZoneAlarm Program Control area, there's 4 green checkmarks at LeechFTP. Any solution?

Discussion is locked
You are posting a reply to: FTP problems - Can't open data connection for LIST
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: FTP problems - Can't open data connection for LIST
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
Re:FTP problems - Can't open data connection for LIST
by R. Proffitt Forum moderator / November 4, 2003 8:12 PM PST

I've always been a thorn in the side of the firewall marketeers because I ask what the firewall does. The marketeers of ZoneAlarm are not documenting their product so you don't know exactly what it's doing.

For instance, in the more classic firewalls I write RULES about what may traverse the firewall.

If you can share your RULES, then we can see what RULE may not be correct.

On top of all this, FTP is going to die soon and be buried next to the GOPHER protocol since FTP has a blaring security issue in that name and password is transmitted in the clear. Anonymous transfers are fine, but name and password connections must be fixed very soon or else.

OK, what to do?

Examine the RULES and consider that Zone Alarm's support on this is a sign of how much marketeering is going on. If you get zero support, then you should pay zero dollars for it. Colors on some graphical tool is not the RULES. We need to see the rules in the classic forms to be able to dissect the issue.

Maybe its time for another firewall?

Bob

Collapse -
Re:Re:FTP problems - Can't open data connection for LIST
by JudySmith / November 5, 2003 10:54 AM PST

???
The problem is with XP, because I never had this problem with [this same version of] ZoneAlarm when using it on Win98.

I was able to have it at the highest security, and I was able to connect via Leech. It's only since XP that I'm having problems.

Any solution?

Collapse -
Solutions.
by R. Proffitt Forum moderator / November 5, 2003 9:37 PM PST

Don't use XP and this firewall together.

You've found something that doesn't work and ZoneLabs isn't supporting you.

Seems simple.

Bob

Collapse -
Re:Re:Re:FTP problems - Can't open data connection for LIST
by R. Proffitt Forum moderator / November 5, 2003 10:18 PM PST

Read Jim's comments about passive. It's needed many times when behind other routers and such.

Bob

Collapse -
Re:FTP problems - Can't open data connection for LIST
by jim c / November 5, 2003 9:34 PM PST

Do you have a DSL connection? If so, there is a setting in Internet Options under the Advanced tab. About halfway down the list is a setting called USE PASSIVE FTP (for DSL and modem compatibility). If you use DSL then maybe you need to check the box next to this setting.

Collapse -
Re:Re:FTP problems - Can't open data connection for LIST
by JudySmith / November 6, 2003 7:42 PM PST

No I don't have DSL.

Collapse -
(NT) Try the PASSIVE MODE of FTP. DSL or not, can help.
by R. Proffitt Forum moderator / November 6, 2003 8:59 PM PST

.

Collapse -
(NT) Wow that solved it - thanks! But - is this safe??
by JudySmith / November 9, 2003 1:12 PM PST

??

Collapse -
re: Wow that solved it - thanks! But - is this safe??
by R. Proffitt Forum moderator / November 9, 2003 8:21 PM PST

FTP is not safe. FTP passes name and password in clear human readable text.

What more can one do to educate others about this?

Bob

Collapse -
Re:re: Wow that solved it - thanks! But - is this safe??
by JudySmith / November 10, 2003 1:06 PM PST

So Bob, what do you use for uploading? Also, what about those HTML editors that have built-in FTP? Thanks for bearing with me...
Wink

Collapse -
If the servers support it...
by Keith Marcotte / November 10, 2003 1:42 PM PST

Secure FTP. PuTTY is a free Windows ssh and sftp client.

Collapse -
And if you want a better interface...
by Keith Marcotte / November 10, 2003 1:51 PM PST
CuteFTP Pro I'm sure there are others but PuTTY and CuteFTP are the ones that I'm familiar with.

I didn't explain in the previous post about the server side. The server has to be running the server-side software for ssh/sftp for this to work. It also uses a different ports than "normal" telnet/ftp processes. It's becoming more common within companies as security audits flag telnet/ftp as security vulnerabilities that need to be closed.
Collapse -
Keith
by JudySmith / November 11, 2003 11:01 AM PST

Keith, is there any free FTP download that's user friendly like Leech, but secure as Putty? Including an automatic download?

Collapse -
Re:Keith
by Edward ODaniel / November 12, 2003 8:44 AM PST
In reply to: Keith

You might take a look at this one from SourceForge

http://winscp.sourceforge.net/eng/

Look over the screenshots (4th button from top in menu on left of page3)

Do yourself a favor and read all about it while at the site.

Enjoy.

Collapse -
Re: Keith
by *natch / August 7, 2004 12:56 AM PDT
In reply to: Keith
Collapse -
Edward - thanks!
by JudySmith / November 13, 2003 3:31 PM PST

Edward, thanks so much for the WinSCP link! It's rated well by Tucows. (Y'know I believe I'd searched Tucows for secure FTP but hadn't found what I sought, so I don't know how you found it.

I'm assuming the download needs to be the first installation package listed under "File"...

I'll try downloading it and see how I find it. Thanks again!

Collapse -
Leech FTP - Can't open data connection for LIST
by lvoget / February 28, 2008 5:58 PM PST

Hi. Me and a colleague are having the same problem with Dell-M90/XP.
Passive mode was already active on my machine.
My machine has just been reformatted.
Leech FTP worked fine on my machine before - now the problem occurs.

Collapse -
Let's make this clear.
by Kees Bakker / February 28, 2008 6:12 PM PST

You did a clean reinstall of Windows XP and LeechFTP doesn't work anymore.
You had passive mode and then you reformatted. Do you still have passive mode?
You're colleague didn't reformat and you're both having the same problem. Then it isn't related to your reformatting, I'd say.

Other things to try and questions:
Can you transfer files using the built-in Windows commandline ftp-program?
Are all Internet-related settings the same on working and non-working machines?
What's your connection with Internet?
What does your IT staff think about the problem'
What firewall are you using?

Kees

Popular Forums
icon
Computer Help 51,912 discussions
icon
Computer Newbies 10,498 discussions
icon
Laptops 20,411 discussions
icon
Security 30,882 discussions
icon
TVs & Home Theaters 21,253 discussions
icon
Windows 10 1,672 discussions
icon
Phones 16,494 discussions
icon
Windows 7 7,855 discussions
icon
Networking & Wireless 15,504 discussions

REVIEW

Meet the drop-resistant Moto Z2 Force

The Moto Z2 Force is really thin, with a fast processor and great battery life. It can survive drops without shattering.