Headphones & Mp3 Players forum

General discussion

Found New Hardware (MTP Device) wont quit popin up!

by dcmarter / January 18, 2007 10:07 AM PST

Just got a MP3 player (Philips SA4010), and did the whole set up process. Ran into afew bumbs like WMP and the Philips Device Manager not connecting with the MP3. Followed the steps provided by Philips to fix the that. After that it both WMP and PDM both connnected with the MP3. Now the only problem is that the "found new hard ware" MTP Device bubble/pop up, what ever you wanna call it, will not stop promting me. Even after I have closed it out, it pops right back up. So my question is, how in the world do I get it to stop, and will that cause the MP3 not being able to sync with WMP??? Help, please I deploy in two weeks and would really like to have the MP3 all set and ready to go!!! Thanxs.

Insigina D300a
2.8 GHz w/ Intel P4
99 GB HD <---thats what it says
512 MB DDR SDRAM <----again, tis what it says
Windows XP SP2

Discussion is locked
You are posting a reply to: Found New Hardware (MTP Device) wont quit popin up!
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Found New Hardware (MTP Device) wont quit popin up!
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
Had the same problem. Fixed it!

So mine has been blinking at my all morning and making this really obnoxious bleeping noise.

Go to Control Panel > Taskbar & Start Menu.

Then on the Taskbar menu hit "Customize" That will show you the current items in your taskbar. You should have one that says "<no title>" - that is the MTP Device. Click on the "Hide when inactive" and change it to "Always hide".

This should have no affect on you being able to put music on your device. Hope this helps, and good luck with everything!

Collapse -
Same problem, but the fix was only temporary
by wjroberts / February 27, 2007 5:41 AM PST

I followed the directions in your post and succeeded in getting the bleeping balloon to go away. However, when I turned my computer on this morning it was back! Is there a way to make the fix permanent?

Collapse -
still no problems...

mine hasn't come back, and i've restarted my computer numerous times. sorry. i'm not sure where to lead you from here.

Collapse -
by meedoy / March 24, 2011 4:07 PM PDT

it worked perfect that thing was driving me crazy for two days

Collapse -
by grdmtl / August 3, 2011 12:20 PM PDT
In reply to: thanks

go to your computer management, click on Device Manager, scroll down to MTP and uninstall it.

Collapse -
It was "drive"ing me crazy!
by xunil1 / November 7, 2011 8:26 AM PST
In reply to: re:mtp

Thanks, it worked. As far as the previous poster that adviced "Always hide"; don't do it that way. Uninstalling the offending driver will take care of it.

Collapse -
by ppravind7 / November 11, 2011 2:20 AM PST
In reply to: re:mtp

Thanks for a showing the way, in my case uninstalling didn't worked, but when i disabled it, it worked.....

Collapse -
by dadsarm / February 15, 2013 6:32 PM PST
In reply to: re:mtp

This one worked for me. Thanks!

Collapse -
by RickOMG / February 18, 2013 2:35 AM PST
In reply to: re:mtp

At work, plug in my phone to charge it, and it would flash and "pop" New Hardware found MTP device.....UGH! I thought I did everything but no luck till I read this. It was a little difficult due to the screen flashing (finding new hardware) but I clicked on it at right time and first disabled it to no result so i uninstalled it. Now phone charging fine now no flashing. THANK YOU! Happy

Collapse -
thank you thank you thank you
by seustache / April 25, 2013 2:10 AM PDT
In reply to: re:mtp

thanks god that you had written the answer here, so i did not go crazy with that popping up MTP Driver found message at every 6-8 seconds

Collapse -
by deer-hunter / March 11, 2007 12:40 PM PDT

Same problem and that worked...thanks, it was driving me nuts!

Collapse -
Cursor still blinks....
by John Rickert / November 13, 2007 4:44 AM PST

Your fix did work. The noise and box is gone. I still however have a blinking cursor. It blinks at the same rate the noise occurred. Is there a way to fix this also?


Collapse -
Many Thanks
by brucehayes / December 20, 2007 11:45 PM PST

You just saved My life.......(Well actually,My Laptops Life)
Had that exact problem all today.Just found this Thread and Presto
my PC is not so F**kin Annoying anymore.

Collapse -
MTP device
by reidythebrief / January 3, 2008 9:04 PM PST

Had the same problem and with your helpful advice I fixed it! Thanks.

Collapse -
Have a very noisy pop-up
by janejsymontt / March 1, 2009 4:13 PM PST

Have a irritating and noisy pop-up saying Found New Hardware MTP device. I followed instructions on posting as far as 'customize'. But my customize button is inactive. How can I change this?

Collapse -
access "customize button" by selecting box to left
by robert crouse / May 13, 2009 11:16 AM PDT

to the left of the customize button is a BOX MARKED

Collapse -
MTP Device Popping Up
by nocomp / April 1, 2009 12:50 AM PDT

The control panel suggestion stopped the pop-up. However, I still am getting the message from my firewall control: "The application wudfhost.exe is the parent of a process that is communicating. Do you want this process to be an 'allowed parent.'" I have Webroot Internet security and it does NOT make a difference if I say allow or block. Every few minutes I get the same firewall pop-up. Please help.

Collapse -
obnoxious message
by ibakh1 / July 30, 2010 2:57 PM PDT

Thank a million for your fix. Kudos to you

Collapse -
Yea! You rock!
by Xena1_us / September 19, 2010 10:45 AM PDT

So simple yet so valuable.

Collapse -
Found New Hardware MTP Device
by Debbiec75 / February 21, 2011 10:02 AM PST

That worked!!!! Thank you so much. The balloon popping up was getting very old!!!

Collapse -
by TuffKitten / August 28, 2011 7:40 AM PDT

Thanks! It worked! But ONLY on my very old HP 5340 ME to XP puter.

Can't stop it on my Vista or 7 Professional puters. Can you tell me how to get it off of those.

If you can't reply soon, you might try reaching me in a padded cell someplace to advise me. OH! Hmmm..... they probably won't let me have my puters in there.


Collapse -
Thank you, thank you!
by ginashel / May 10, 2012 9:05 AM PDT

I had the same problem after installing a Sansa Zip Clip mp3 player -- driving me nuts. Your fix seems to have done the trick. (I hope it doesn't come back!)

Collapse -
Thanks I'll try it, DAMN ANNOYING
by winburn / May 11, 2012 2:33 PM PDT

Thanks I'll try it, DAMN ANNOYING THANKS

Collapse -
nice fix
by kjsfhfskihfs / September 29, 2012 4:12 AM PDT

you are da man

Collapse -
Excellent advice!
by PLMatthews88 / October 10, 2012 1:05 PM PDT

Spot on, friend. Thanks!

Collapse -
by topo990 / February 11, 2013 4:05 PM PST

Woarked for me. Thank you

Collapse -
MTP device keeps popping up.
by woowoo2u / March 11, 2007 12:04 PM PDT

go to device manager. You will find MTP with a yellow mark on it. Right click properties and uninstall. That should fix the problem. I had the same and this took care of it.

Collapse -
Better fix
by deer-hunter / March 11, 2007 12:50 PM PDT

Thanks...I did the always hide fix first and that worked but I was unable to access add hardware....by uninstalling I was able to use the add hdwe wizard again...thanks!

Collapse -
by louietyj / March 31, 2007 6:40 PM PDT
In reply to: Better fix

Yes, the "always hide" takes away the sound, but it does not take away the CPU usage...it is slowing down my system dramatically...

How to get to the Device Manager?

Collapse -
Device manager
by willisbd / May 29, 2007 11:13 PM PDT
In reply to: ...

This message is probably late for the original poster, but for completeness... To get to Device Manager: Control Panel/System Properties/Hardware/Device Manager. I found that the MTP Device icon was sort of flashing because it was apparently still trying to install. I had to do the right click quickly when the icon popped up.

Popular Forums
Computer Help 51,912 discussions
Computer Newbies 10,498 discussions
Laptops 20,411 discussions
Security 30,882 discussions
TVs & Home Theaters 21,253 discussions
Windows 10 1,672 discussions
Phones 16,494 discussions
Windows 7 7,855 discussions
Networking & Wireless 15,504 discussions


Want to see the future of car technology?

Brian Cooley found it for you at CES 2017 in Las Vegas and the North American International Auto Show in Detroit.