Well, this is a question for Compaq guys. Did you contact them ? Sounds like the keyboard or internal ribbon has some contact problems.

As for the Ctrl Alt Del combo, is your PC connected to a domain or standalone ? In either cases, there is a policy in order to restrict the Ctrl Alt Del at logon that is named:

Disable CTRL+ALT+DEL requirement for logon

Good Luck,

Cetin


Trying to unweave, unwind, unravel
And piece together the past and the future,


T. S. Eliot