Browsers, E-mail, & Web Apps forum

General discussion

Firefox problem

I have been using Firefox for a long time and all of a sudden it will not set cookies or retain passwords. I cannot log into yahoo mail at all or I get a '999 Error' message. Under 'Options' it is set to accept cookies. I have no problems with IE - it's functioning normally. I don't recall changing any settings and I don't have any of my security apps configured differently than normal. I tried uninstalling and reinstalling Firefox, but no change. Any ideas?

Thanks.

Discussion is locked
You are posting a reply to: Firefox problem
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Firefox problem
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
Go to

In reply to: Firefox problem

Go to

tools

options

cookies

and checkmark the box allow websites to set cookies

click ok then close Firefox and restart it.


Hope this helps.

Collapse -
Cookies

In reply to: Go to

It is already set to accept cookies.

Collapse -
Something to check

In reply to: Cookies

See that the date and time (including the year) are set correctly on the computer. This might seem an unlikely cause but I've come across it a few times before. Easy to check anyway.

Collapse -
(NT) (NT) Time & Date are OK - thanks.

In reply to: Something to check

Collapse -
What I do when that happens.

In reply to: Firefox problem

I uninstall it, then install the latest version.

Bob

Collapse -
(NT) (NT) I tried reinstalling - no change.

In reply to: What I do when that happens.

Collapse -
If the 999 link doesn't work, then profile time.

In reply to: (NT) I tried reinstalling - no change.

Backup your favorites and cookies then delete the profile directory as well then install.

Bob

Collapse -
Profile Directory

In reply to: If the 999 link doesn't work, then profile time.

When you say to delete the profile directory, do you mean to go into Windows Explorer and delete everything under 'Firefox' in the Program Files? Or is there more than that somewhere else?

Thanks.

Collapse -
Location of the profile directory...

In reply to: Profile Directory

In Windows XP, the profile directory is located at ''local drive:\Documents and Settings\username\Application Data\Mozilla\Firefox\Profiles\random folder name''. This data is not deleted when uninstalling Firefox, and if corrupted, must be removed manually. Just uninstall Firefox, delete the Firefox directory in Program Files, then delete the above profile directory. But, before you do, MAKE SURE you backup the files bookmarks.html and bookmarks.bak. After reinstalling Firefox, a new profile directory will be created for you. At that time, delete the auto-created bookmarks.html and bookmarks.bak files, and replace them with your backups. You can then launch Firefox (which should be problem-free), verify your bookmarks are present, reset your preferences, and reinstall any/all extensions/themes you had previously.

Hope this helps,
John

Collapse -
Deleted the profile directory....

In reply to: Location of the profile directory...

...and did a clean reinstall of Firefox - but still no access to Yahoo. Guess the problem is with Yahoo itself. For the time being I will use IE and hope that a problem doesn't develop with it also, or I will be out of luck.

Thanks.

Collapse -
Error 999

In reply to: Firefox problem

Collapse -
Thank you.....

In reply to: Error 999

I will try some of the suggestions in that link.

Collapse -
I seem to have found an answer...

In reply to: Thank you.....

In the Yahoo sign-in box there is a mode selection. If I choose 'secure' over 'standard', I can log in successfully in Firefox. It doesn't seem to matter what mode I select with IE - I can get in anyway. Found the answer on an obscure forum that has nothing to do with computers!

Popular Forums

icon
Computer Newbies 10,686 discussions
icon
Computer Help 54,365 discussions
icon
Laptops 21,181 discussions
icon
Networking & Wireless 16,313 discussions
icon
Phones 17,137 discussions
icon
Security 31,287 discussions
icon
TVs & Home Theaters 22,101 discussions
icon
Windows 7 8,164 discussions
icon
Windows 10 2,657 discussions

DEALS, DEALS, DEALS!

Best Black Friday Deals

CNET editors are busy culling the list and highlighting what we think are the best deals out there this holiday season.