Browsers, E-mail, & Web Apps forum

General discussion

Firefox not fully the default browser in Vista!!!

by jhnsn283 / June 16, 2007 6:57 AM PDT

Since the time I installed Windows Vista, there have been several apps that just will not except the fact that my default web browser is Firefox. Instead, IE will be launched. I have learned to work around the problem, but checking my emails with a third party notifier made me want XP back. The email notifier checks my two gmail accounts and my wife's gmail account. In XP all I had to do was click on the email that had the messages and I would auto login into my account within firefox. Now with Vista, it would launch IE instead of firefox. I have checked default apps under Vista and Firefox which both agree that Firefox is the default. For some reason though it was not working. Not only did it launch the wrong browser, but after checking one email account, I would have to manually log off and not just close the browser to check another account.

Here is the surprising fix that corrected it all. Thank you Apple for Safari! Not that I enjoy it better than Firefox. I could never give up my extensions. Safari, under preferences, showed that IE was my default browser. I quickly changed it to Firefox and now all my apps recognize Firefox as my default app. Now I no Vista has made some changes from XP which is the culprit in this case, but I suggest that Mozilla finds out how Safari made better sure that Firefox was the default browser than Firefox itself.

Discussion is locked
You are posting a reply to: Firefox not fully the default browser in Vista!!!
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Firefox not fully the default browser in Vista!!!
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
firefox on vista fix
by qualex / August 6, 2007 5:38 AM PDT

Thanks so much for the tip! It was a great help.

Collapse -
making ff2 the default for urls
by marg_it / September 1, 2007 6:44 PM PDT

Yeah, ie7 opening links by default was annoying. Firefox is also set as my default browser, but I noticed ie7 remained the default for three file types, including .url. I poked default programs a bit and discovered how to make the switch:
Start, Default Programs, Associate a file type or protcol with a program, scroll to .url, select "change program", and browse to the mozilla firefox folder, select firefox, okay.

YaYs!

Collapse -
that's how they did it
by jhnsn283 / September 2, 2007 2:22 AM PDT

Good find. I was wondering where the fix really was. Thanks!

Collapse -
This totally worked!
by mattarata / September 12, 2007 9:03 AM PDT

Thanks to the OP for this fix. I had tried changing defaults in many different places all over Vista with zero luck...i had basically given up....

Recently I decided to look for a fix again, googled and found this post.

THANKS!!!!

Collapse -
Default Browser
by LinuxDude71178 / November 28, 2007 5:42 PM PST

Go to Start => Run and then Type
firefox.exe -silent -setDefaultBrowser

Now every link will open only in Firefox.

Collapse -
works now!
by chisaikame / March 9, 2008 10:37 PM PDT
In reply to: Default Browser

thank you for the OP, and for the command linux dude.. worked like a charm! Grin

Collapse -
reverse
by chisaikame / March 9, 2008 11:10 PM PDT
In reply to: Default Browser

hey Linux dude, i was trying safari and seems to be working better blocking pop ups than firefox... do you have any idea how to reverse the command to set ff as default browser? thanks.

Collapse -
No reversal, but...
by John.Wilkinson / March 10, 2008 2:56 AM PDT
In reply to: reverse

In Safari try going Edit->Preferences->General->Default Web Browser to set Safari as the default. Similar options are available inside Firefox, Internet Explorer, Opera, etc.

John

Collapse -
Making sure Firefox is truly the default browser under Vista
by ppmartin / April 7, 2008 11:20 PM PDT
In reply to: Default Browser

Many thanks, LinuxDude71178, this command worked like a charm ... it is simple, yet it "sticks".

Collapse -
Thanks!
by abanium / April 10, 2008 5:34 AM PDT
In reply to: Default Browser

You're a a genius Linux Dude..

Collapse -
thanks
by pboulerie / February 25, 2010 4:05 PM PST
In reply to: Thanks!

thanks to LinuxDude71178.

Popular Forums
icon
Computer Newbies 10,686 discussions
icon
Computer Help 54,365 discussions
icon
Laptops 21,181 discussions
icon
Networking & Wireless 16,313 discussions
icon
Phones 17,137 discussions
icon
Security 31,287 discussions
icon
TVs & Home Theaters 22,101 discussions
icon
Windows 7 8,164 discussions
icon
Windows 10 2,657 discussions

CNET FORUMS TOP DISCUSSION

Help, my PC with Windows 10 won't shut down properly

Since upgrading to Windows 10 my computer won't shut down properly. I use the menu button shutdown and the screen goes blank, but the system does not fully shut down. The only way to get it to shut down is to hold the physical power button down till it shuts down. Any suggestions?