NT4 has long since been abandoned by MS, and there are a large number of security issues with it that will never be fixed. It's not really a wise idea to still be using it. I think Windows 2000 just saw it's last major security update come out yesterday.

My guess would be that your system has been pegged by all kinds of nasties, and that's the cause of your problems.

It's time to get rid of NT4 in favor of something else. If the system's too old to run XP comfortably, give Linux a shot. You really should be running something that's being actively maintained.