Attention: The forums will be placed on read only mode this Saturday (Oct. 20, 2018)

During this outage (6:30 AM to 8 PM PDT) the forums will be placed on read only mode. We apologize for this inconvenience. Click here to read details

Windows 7 forum

Question

Files encrypted and access denied.

by Mr_Sheerdil / April 16, 2014 9:48 PM PDT

Hi all,
I have been into a little technical stuff but now stuck in a situation so need ur kind help.
The Situation: I don't know how and when few of my files (mostly in C drive) got encrypted and are now can't be opened, viewed and played. I recieve notification that you don't have correct permissions.
Things tried: 1. Decrypt file by going in advanced option in file properties.
2. Tried a lot of security settings manipulation.(Allowed full control,etc.)
3. Tried everything in User Accounts under Control Panel.
4. Tried to copy files using Linux boot cd, ERD, etc. but no luck so far.

Note: A few days back I received a pdf file (a payment confirmation) with not digitally certified message, so downloaded a respective .p7b file from its website and installed in my computer. The import/install was successful but just wondering could this be the cause of problem. i.e. could certificates be causing this issue.
Can't reinstall Windows as the affected files are a must needed to me.

Discussion is locked
You are posting a reply to: Files encrypted and access denied.
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Files encrypted and access denied.
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
Clarification Request
Tell more about the Linux use.
by R. Proffitt Forum moderator / April 16, 2014 9:57 PM PDT

Unless you encrypted the drive, FILES copy out just fine. I wonder if the issue is that the association has been lost.

But as presented you make a great case to restore from your last backup. It's obvious you can't lose files so you would be backing up as a rule and not taking chances.

-> Try this. Take a common file type, some document and put it up on Dropbox on a public link and share it here so folk can test if it opens for them.
Bob

All Answers

Collapse -
Answer
Re: files
by Kees_B Forum moderator / April 16, 2014 10:12 PM PDT

- Permissions and encryption are different things. The issue really isn't clear.
- The copy from Linux issue isn't clear at all, as Bob already noticed.
- Copying an encrypted file is rather useless anyway.

Reinstalling Windows usually does nothing with user files, unless you format the drive. A few folders are saved in windows.old, other folders just stay where they are with all their contents unchanged.

For me, this smells like malware. Then reinstalling Windows might be the only good solution.

Kees

Collapse -
Few clarifications
by Mr_Sheerdil / April 17, 2014 9:06 PM PDT
In reply to: Re: files

@Kees
- (1) My files are encrypted( right click->prop->advanced->encrypt content to secure data is enabled) when I try to uncheck or decrypt it asks for admin privileges, which I have but cant regulate.
-(2) Using Linux to recover my files so that I can reinstall windows by formatting PC.
-(3) I know encrypting files are useless unless u know password or something but friend these files are imp to me and as mentioned I didn't encrypted them.

@Bob: "association has been lost." means, can you guide something about this.
I will put some files asap.

Collapse -
Re: clarifications
by Kees_B Forum moderator / April 17, 2014 9:19 PM PDT
In reply to: Few clarifications

1. What do you mean by "regulate"?
2. Linux won't help to decrypt files. Only to copy them to copy them to another device, where they stay useless.
3. If you didn't, maybe malware did. That's why you need a backup.

I don't think this is about file associations. But we'll know for sure if you made such a file available for us in Dropbox or such a file sharing service.

Kees

Collapse -
Some more clarifications
by Mr_Sheerdil / April 18, 2014 11:42 PM PDT
In reply to: Re: clarifications

By regulate I meant apply i.e I am admin but cant apply the changes. Always gets "error applying attributes" and access denied.
Scanned for malwares and viruses but no infections found(used AVG)
Could the certificate installation be the cause of problem.

Collapse -
OK, AVG and other suited can stand inbetween
by R. Proffitt Forum moderator / April 19, 2014 1:35 AM PDT

And block such changes. When this happens I find myself returning to a pristine system. All Microsoft. Then I am sure the malware (which is not detected by AVG!!!) and these suites are not "protecting" against those changes.

To scan for malware you may be new to this area but there is no single solution to find and remove malware. Grif shares a list of tools at http://forums.cnet.com/7726-6122_102-5509131.html?tag=posts;msg5509131

So at this poing I'm thinking 2 things.
1. Get rid of the protection and try again.
2. Scan with Grif's tools, clean off what it finds and try again.

But before all that, backup the drive to some external. I use Clonezilla but your choice on that.
Bob

Collapse -
Grif Tools
by Mr_Sheerdil / April 23, 2014 2:56 PM PDT

I will surely try this and post the scan results soon.

Collapse -
can you right clk these files
by James Denison / April 24, 2014 12:04 AM PDT

and choose the program they normally open with and get access to them that way? For choice of programs, hold the Shift key and then do the right clk, that will let you find the program you'd like to try if it's not the default one anymore. It may be the file association to particular program has changed by accident. Are all the files you can't access of the same type?

Collapse -
Right click thing won't help
by Mr_Sheerdil / April 26, 2014 4:38 PM PDT

The files are images, text docs and videos. So not same types of files.
I think shift thing not gonna help.

Collapse -
Given the new detail, I doubt it's association.
by R. Proffitt Forum moderator / April 18, 2014 1:49 AM PDT
In reply to: Few clarifications

And recovering these after a format does cost a little. I think http://www.lostpassword.com does this work.

Microsoft, no, and again no does not help you as they, well, let's just say they are not going to help folk decrypt files unless you are NSA, CIA, FBI, DOJ, etc.

What is this "regulate"?
Bob

Collapse -
hmm
by James Denison / April 21, 2014 3:52 AM PDT
In reply to: Few clarifications
-(3) "I know encrypting files are useless unless u know password or something but friend these files are imp to me and as mentioned I didn't encrypted them."

You didn't encrypt them, but they are now encrypted. Were they files belonging to another user on your computer who encrypted them? Did you have a username for yourself you changed?
Collapse -
Answer
by Mr_Sheerdil / April 23, 2014 3:05 PM PDT
In reply to: hmm

Yes I didn't encrypted these files. Never ever. No I have only one User account i.e mine and never changed username.

But I am getting to think now, that my computer is taking some other user as the owner of these particular files only.
I can encrypt or decrypt any file on my hard disk other than these files.

Collapse -
Answer
p7b
by James Denison / April 21, 2014 3:50 AM PDT
info about that type of certificate file

I remember a thread in the past year where someone else did the exact same thing and lost access to some files. I'll see if I can find it, but maybe you can look around for it too. Don't remember the outcome of it.

You had access to these files before and they weren't encrypted at the time? Or did you have just the folder they were in encrypted? Or all your data encrypted?
Collapse -
p7b
by Mr_Sheerdil / April 23, 2014 3:10 PM PDT
In reply to: p7b

Yes I had access to these files, I regularly maintain these files and were not encrypted. No not all my data is encrypted, the files that got affected were mostly on my desktop and few other files in other drives(other than C drive).

Collapse -
OK, if this don't work
by James Denison / April 23, 2014 11:44 PM PDT
In reply to: p7b

probably nothing will.

I suspect maybe some electrical event, maybe excess ripple from the power source, or hard drive data corruption on the files affected in some way.

If you can download a Linux distro as ISO, burn the "Image" to disc, and then boot to it, you can use that to reclaim the files. You may already have some boot rescue disc there you can do the same with. Linux pays no attention to Windows permissons and will allow you to copy those files to a FAT32 formatted drive which will strip off the permissions from an NTFS formatted drive. A thumbdrive (flashdrive) is good for this since most are FAT32. You can then boot back into windows, copy the files from the flashdrive or FAT32 partition on your harddrive if you have such, into your personal folders (My Documents) and they will become YOUR files again. As for them being encrypted, if that's the case, at least you will have access to them.

http://blog.linuxmint.com/?p=2493

http://mirror.umd.edu/linuxmint/images/stable/16/linuxmint-16-mate-dvd-32bit.iso

http://www.linuxmint.com/documentation/user-guide/english_15.0.pdf

Collapse -
I doubt this!
by Mr_Sheerdil / April 26, 2014 4:55 PM PDT
In reply to: OK, if this don't work

I cant take the electrical event to be true as only few files are affected.
I am already having dual boot(Windows+Linux). Also used Linux live CD but always get access denied or not appropriate permissions.
Also as already discussed there is no point of copying encrypted file unless you are user or authenticated person.


Please any one can suggest something else.

Collapse -
didnt work
by Mr_Sheerdil / April 23, 2014 3:25 PM PDT
In reply to: info

I read the link you posted and also tried AxCrypt and some other Encryption/Decryption tools, but got same error cannot perform the actions as access is denied or user not authorized.

Collapse -
Answer
For Decrypt Files
by Guysavoy1 / April 23, 2014 9:01 PM PDT

Popular Forums

icon
Computer Newbies 10,686 discussions
icon
Computer Help 54,365 discussions
icon
Laptops 21,181 discussions
icon
Networking & Wireless 16,313 discussions
icon
Phones 17,137 discussions
icon
Security 31,287 discussions
icon
TVs & Home Theaters 22,101 discussions
icon
Windows 7 8,164 discussions
icon
Windows 10 2,657 discussions

FALL TV PREMIERES

Your favorite shows are back!

Don’t miss your dramas, sitcoms and reality shows. Find out when and where they’re airing!