Right click the recycle bin.
Click Properties.
Make sure Use one setting for all drives:is selected.
Check the box,Do not move files to the Recycle Bin.
Click OK.
That will completely disable the recycle bin.
Reboot,then re-enable the recycle bin.

Tom