Web Hosting, Design, & Coding forum

Question

Fetch as google is not working properly for my site

I write an unique article for example : about an unrelished smartphone and after publishing it I go to webmaster tools and go to fetch as google from crawl option... Everything happens properly from the webmaster. But the problem is that I can't find my post in google ssearch though I have done fetch as google.. These problem is happening for many posts I have recently written..
I checked my posts serps from many tools so that I can know my page rank but the result shows can't found...
So I need help about why google is not showing my post after doing fetch as Google...
Plz help me if you are familiar with the problem..
Thnx

Discussion is locked
You are posting a reply to: Fetch as google is not working properly for my site
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Fetch as google is not working properly for my site
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.

All Answers

Collapse -
Answer
I'd post this on a Google Product Forum.

In reply to: Fetch as google is not working properly for my site

Collapse -
Answer
Try searching for your post

In reply to: Fetch as google is not working properly for my site

by title and site name. For example, if I wrote a post titled "How to build a web application" and my domain/site is hello.com, then try searching for:

"How to build a web application" hello.com

This should show you your post in Google. If it doesn't appear at all, then perhaps it hasn't been indexed yet or search engines have been discouraged from indexing your website.

I believe fetching as Google only acts as a preview of what it would look like, but doesn't actually index the content.

Popular Forums

icon
Computer Newbies 10,686 discussions
icon
Computer Help 54,365 discussions
icon
Laptops 21,181 discussions
icon
Networking & Wireless 16,313 discussions
icon
Phones 17,137 discussions
icon
Security 31,287 discussions
icon
TVs & Home Theaters 22,101 discussions
icon
Windows 7 8,164 discussions
icon
Windows 10 2,657 discussions

DEALS, DEALS, DEALS!

Best Black Friday Deals

CNET editors are busy culling the list and highlighting what we think are the best deals out there this holiday season.