Photo Editing & Graphic Design forum

Resolved Question

FastStone problem

by robert.bev / January 7, 2012 3:13 AM PST

<font face="Arial, sans-serif">Windows7
SP1 32 bit
BIOS Award F3 V6 00PG
Gigabyte H55M-D2H rev 1.4</font>
<font face="Arial, sans-serif">500Gb
<font face="Arial, sans-serif">Intel
Core i3 550</font>
<font face="Arial, sans-serif">Memory
2 x 4096</font>
<font face="Arial, sans-serif">Nvidia
GeForce GTS 450 </font>
<font face="Arial, sans-serif">Controller
Intel 3400 2port ATA- 3B26
Comodo Firewall</font>
<font face="Arial, sans-serif">Avast
- Anti virus</font>
Hi all
I am using FastStone image viewer, and after I have altered a photo I try to save the changes and I get the message " Failed to save the file, it may be read only or used by another program"
I know the program is not open any where else, so can anybody inform me how to check if its "read only"?
Regards Robert.

robert.bev has chosen the best answer to their question. View answer
Discussion is locked
You are posting a reply to: FastStone problem
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: FastStone problem
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.

All Answers

Best Answer chosen by robert.bev

Collapse -
I've posted
by MarkFlax Forum moderator / January 15, 2012 6:12 AM PST
In reply to: FastStone problem

all the way down here as we are fast approaching the forum software limit for sub-threads.

I'm glad you got it sorted by finding another software app that works. Good work.

But I'm still intrigued. Happy

I would love to see a screen print of your "Computer", (the one in the Start menu) to see how Win 7 is listing all these drives. I just wonder if that ( I: ) is a Volume Label.

If you want to end this now then that's fine, but if you wanted to send a screen print of the open "Computer" window, do that, paste it into Paint, remove any personal details that might show, although it shouldn't, save the file as a JPEG, then upload it to some image hosting site like ImageShack, Flickr or PhotoBucket, and paste the link to that full sized image in a post here.

Ohh, and just one more thing. if you open Explorer, (Computer will do or any other Explorer window), navigate to where these pictures are, what happens if you attempt to rename one of them? (Select one, right click, select Rename, change the name then hit Enter). Does Explorer allow that, or does it display an error message? if a message what are those words?


Collapse -
by robert.bev / January 17, 2012 12:46 AM PST
In reply to: I've posted{5DF7CFA3-A6B3-4263-89FA-3FF030F413CC}&uploader=aurigma

Hi Mark, I have managed to put a couple of photos on Photobox, and I have copied the address above, I hope it works.
I have also changed the titles of some photos in the album with no problem, and as I try other photos in the album, some alterations will save others will not, the photos have been taken with three different cameras but I don't think that has anything to do with the problem as all was ok when I was using PSP and XP Pro, I am now begining to think that the problem is with the FastStone image viewer.
Regards Robert.
Collapse -
by MarkFlax Forum moderator / January 17, 2012 4:11 AM PST
In reply to: Hi

I couldn't get the link to work.

The link was;{5DF7CFA3-A6B3-4263-89FA-3FF030F413CC}&uploader=aurigma

but the - {5DF7CFA3-A6B3-4263-89FA-3FF030F413CC}&uploader=aurigma - part was missing from it and when I clicked the remaining link all I got was the page with a "Photo album empty" message.

When I manually added the - {5DF7CFA3-A6B3-4263-89FA-3FF030F413CC}&uploader=aurigma - to the lin in the address bar, all I get is an error page.

I don't want to see photo files. I just want to see a screen print of your "Computer", (what displays when you click "Computer" in the Start menu).


Collapse -
Hi, second try :-)
by robert.bev / January 18, 2012 7:34 AM PST
In reply to: Ahh

Hi Mark, If you think this thread has run long
enough then I thank you for your interest and your help.

As the photos do allow a name change without
problem, and as it's only certain photos that will not save the
changes, I now feel sure it is the FastStone viewer which is at fault,
and I will try something else.

Sorry the links I sent you were duff, I must have
got something wrong, but anyway for your information I have managed to put two screen
shots on another site, and by the Blue colour of the links I have
pasted I think they will work, so you will get an idea of what I have
pointed out.

If you want to comment further I do appreciate
your opinion, regards Robert.

Collapse -
My own image
by MarkFlax Forum moderator / January 18, 2012 7:27 PM PST
In reply to: Hi, second try :-)

This is what I was hoping for;

You may have to click the magnifier to enlarge it.

That is the screen print of my own "Computer". Your setup seems strange. You say this is a Win 7 OS but the first image you provide looks like a very old Win 95/98 OS setup, or perhaps even XP. So I am guessing you have modified the OS in some way to get that 'retro' look.

I'm quite happy to wander along with this, (in my old age), but I know that you have now solved the problem, albeit a workaround, so it was more out of interest really.

So if were done then good luck and farewell. Devil


Collapse -
Here is another
by robert.bev / January 18, 2012 9:38 PM PST
In reply to: My own image
Collapse -
It's very interesting
by MarkFlax Forum moderator / January 19, 2012 9:10 PM PST
In reply to: Here is another

and I don't know where you go from here, Sad

I mentioned above, (somewhere), the problems that can occur when the OS is not installed on the C drive, and you've just stated that you are having so many problems getting other programs to work with Win 7. I am betting this is why.

The thing I find strange is this. When any Windows OS installs itself on to a boot drive, whether or not it is partitioned into separate partitions, and whether or not there is more than one drive connected, (internally), the OS will always call itself as installed on the C drive.

It works like this. If I have one drive in my computer but with 3 partitions, then I might have different OSes on each partition, eg first partition has XP, 2nd partition has Vista, and 3rd partition has Win 7. This would be a dual or multi-boot setup. But whichever OS I boot into, it sees itself as installed on C, and the other partitions are just treated as D, E, F, etc.

That's automatic and unless the user/installer takes 'specific steps' to rename the drive to something else, each OS calls itself as installed on the C drive.

And that's why I find it strange that this Win 7 is installed on I

Add to that, your Win 7 OS seems heavily modified because the display is non-standard and looks like an old Win 95 or 98 setup.

If this were me I would be tempted simply to start over, disconnect any external drives and install Win 7 afresh. No changes, stock install. The Setup should ask which partition to install onto, so I would choose a partition, format that, and install onto that and from then on it will call that C when you boot into it.


Collapse -
Many thanks
by robert.bev / January 19, 2012 11:47 PM PST
In reply to: It's very interesting

Hi Mark, yes it is odd, but the instructions said
to just put in the disk and install over XP which I did, I think you
are correct in your assumption and it would be a good idea to
reinstall the OS, it's just a pain doing so, normally I would have F
disk'ed first, but this time I didn't and that is probably where the
fault and problems lay.

Anyway my thanks for your help and input, I am
most grateful, and as we are limited by forum rules I think we had better call this thread closed,
best of regards Robert.

Collapse -
In Explorer
by R. Proffitt Forum moderator / January 7, 2012 3:42 AM PST
In reply to: FastStone problem

Select the file and right click properties.

Also see if the FOLDER is read only. Same method.

Collapse -
Does this happen
by MarkFlax Forum moderator / January 7, 2012 3:45 AM PST
In reply to: FastStone problem

on all image files or just some?

I see you're using Windows 7 32 bit.

Where is this photo stored? On a folder in Win 7, (which one), or some other media?


Collapse -
thanks for your response.
by robert.bev / January 7, 2012 4:44 AM PST
In reply to: Does this happen

Hi Guys, thanks for your response.
The folder where my photos are kept is on a slave drive dedicated only to photo albums.
I have checked the folders as Bob suggests and the folder has a greyed out check and the message "Read Only- Applies to files in folder, but when I click on the photo that I can't alter the "Read Only and Hidden" are both unchecked.
Regards Robert.

Collapse -
There are other reasons
by R. Proffitt Forum moderator / January 7, 2012 4:48 AM PST

Such as too many files in the top folder or an odd named file. It's something but I can't tell yet.

Collapse -
Slave drive
by MarkFlax Forum moderator / January 7, 2012 5:06 AM PST

Can you tell us what that is? it's unusual to have a slave drive on a Windows 7 system.

Have you transferred this drive from some other system recently? or have you installed or 'reinstalled' Win 7 on this system recently? If so, this might be an "Ownership" problem that won't be fixed simply by using an Admn capable account.

What I am really asking is, Has this ever worked? If so, what has changed since then?


Collapse -
Hi again
by robert.bev / January 8, 2012 1:03 AM PST
In reply to: Slave drive

Hi again
Windows7 Pro op system is on a 500 Gb HDD
I am sorry to mislead you, I
have two other slave drives installed that are not listed in my PC
specifications above, both of which do not have an operating system on them, in effect they
are just storage drives.
The dedicated drive that I use
for photos has 27 folders on it, each folder containing albums of photos,
for example the "Holiday" folder contains 25 albums each
containing about 200/300 photos.

When I was using XP Pro
and Paint shop Pro as my photo managing program I had no problem at
all, but PSP will not work with W7 so I have found FastStone which I
think will be ok once this prob is solved
Regards Robert.

Collapse -
Not listed in your PC
by MarkFlax Forum moderator / January 8, 2012 5:04 AM PST
In reply to: Hi again

I wonder if that's a clue to the problem.

Have you tried connecting these drives via USB drive enclosures, instead of connecting them inside the machine itself?


Collapse -
Hi Mark
by robert.bev / January 10, 2012 7:57 AM PST
In reply to: Not listed in your PC

Hi Mark,
thanks for your suggestions, (Not listed
in your PC) sorry I was apologising for not listing the storage
drives in the PC specifications above, the storage drives do show as
C: and E: on my PC.

I have just altered some pictures with Fastone
Image Viewer with no problem, but the pix were on a memory stick and
not the HDD, I wonder if it is as you suggest, an ownership problem?

I am not sure what you mean by "connecting
these drives via USB drive enclosures" are you suggesting that I
should make them external drives via USB cables? as I stated above
they worked OK with XP and PSP I think the prob is in FastStone.
Regards Robert.

Collapse -
Before we go any further
by MarkFlax Forum moderator / January 10, 2012 8:05 AM PST
In reply to: Hi Mark

and quickly to get it out the way, can you clarify, "the storage drives so show as C: and E: on my PC",

I'm betting that's an error, (I make typing errors all the time much to my dismay), but if not, if C: is a storage drive, where is Windows 7 OS installed?


Collapse -
Ohh and whilst we're at it
by MarkFlax Forum moderator / January 10, 2012 8:07 AM PST

a quick test...

Open one of those pictures from the storage drive in Paint, (it's pre-installed on Win 7 of course), and resize it. Can you save it? If not, what is the full error message please?

Collapse -
Hi Mark
by robert.bev / January 13, 2012 6:58 PM PST

Hi Mark, sorry for the delay as I did not get a warning mail to prod me into action :-).
Here is the info you wanted, when I loaded Win7 Pro the distructions said that there was no need to F Disk the drive, so I think the program must overwrite the XP on it, and it gave me the new drive number as (I:) so now Local Disk ( I: ) is the HDD with the operating system on it.
The storage drives are numbered C and E and while c is a general storage drive, and e has all the photo albums on it.
as you suggested I have opened a photo and altered it, then I clicked to save it and got the message again, so next I made a copy of the same photo and opened it with paint, and I resized it down to 75% and it saved OK with no problem.
I have the same photos on a memory stick and they also alter with no problem, so it seems that it's just the photos on the (E:) drive. Regards Robert

Collapse -
by MarkFlax Forum moderator / January 13, 2012 9:48 PM PST
In reply to: Hi Mark

It looks like you installed Win 7 into a separate partition on the main hard drive.

Do you not have a dual boot with XP as the other option?

It is unusual for Windows to consider itself on any drive or partition other than C, and in fact if you open "Computer" from the Start menu it should still show "{Name of disk} (C:)"

That means that, whichever OS is booted up, Windows regards itself as installed on C:

It can cause problems if not that, because many applications expect to be installed on the C drive and their coding looks for files and data on C.

So, I'm right confused! Sad

But I am now thinking, (as suggested before), this is an Ownership problem.

If so, you will have to take ownership of the drive in question, and guidance here;

HOWEVER - here's a problem. In the link below is a warning, "Do Not Take Ownership Of The C Drive";

Tricky. You need to be absolutely sure what these drives and partitions are before proceeding.


Collapse -
Hi again
by robert.bev / January 14, 2012 9:30 PM PST
In reply to: Interesting.

Hi Mark, thanks for your help, Windows7 is made to
install over XP but I don't know why Windows gave the letter ( I ) to
the Local Disk as the Operating System, that was a bit odd.
The old C partition must have been overwritten and
I am not having any other problems as any new programs that I install
automatically install without any problem on "Local disk (I:)

There is no dual boot as XP has gone, and the
drive letter C was given to the 250Gb storage drive when I first
connected it to the PC, and the 80Gb photo storage drive was given
the letter (E:)
I will have a look at the articles that you have
sent, which at first view looks a little complicated, but anyway with
a bit of luck taking ownership of the drive might not be needed, as
last night I opened another album not previously tried, and the
photos inside could be worked on and the alterations saved with no
So it's possible that the problem might be with
the the specific album, or photos within it.

Regards Robert.

Popular Forums
Computer Help 51,912 discussions
Computer Newbies 10,498 discussions
Laptops 20,411 discussions
Security 30,882 discussions
TVs & Home Theaters 21,253 discussions
Windows 10 1,672 discussions
Phones 16,494 discussions
Windows 7 7,855 discussions
Networking & Wireless 15,504 discussions


Samsung Galaxy S8's major makeover

This year's flagship phone gets a sexy new design and Bixby, a house-made digital assistant.