Windows Legacy OS forum

General discussion

External Mass Storage Device

by estcst_kevin / August 22, 2006 2:11 AM PDT

Windows XP Home does not recognize Mass Storage Device

I've been using an external storage device to back-up all my important files. I usually un-plug the back-up drive when I?m done, but this time I forgot. There was a power outage and now XP does not recognize the drive as what I had it named as (backup drive). It now recognizes it as local drive I and not as a Mass storage device (USB) and wants to format the drive. I had all my college courses information on that drive and now I can?t view any of it. I hope I have not lost those files permanently. Please somebody save me. I also failed to make an additional copy of everything. I am learning this backup stuff the hard way. Another thing, I tried recovery console and had no luck there either.--

Discussion is locked
You are posting a reply to: External Mass Storage Device
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: External Mass Storage Device
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
Link, comment.
by R. Proffitt Forum moderator / August 22, 2006 2:17 AM PDT
Collapse -
problem not resolved yet
by estcst_kevin / August 22, 2006 11:49 PM PDT
In reply to: Link, comment.

I tried the other computer, the rear USB port on my PC, and the cmd prompt solution [chkdsk n: /f] with no luck. I don?t think this will help, but it?s not a Maxtor drive. The name is Fantom Drive. I would guess they are basically the same. I?ve also tried one of the links on the other post that leads to a recommended solution and had no luck there as well.

Collapse -
Fantom or other.
by R. Proffitt Forum moderator / August 23, 2006 12:11 AM PDT

The discussion covers about every method known to get files out, the drive working again or repaired.

Since the easy steps fail (other PCs) then the unit has failed. I put the drive in another USB housing first since that's the likely next best solution.

Best of luck,


Collapse -
installed as internal slave drive
by estcst_kevin / August 23, 2006 4:22 AM PDT
In reply to: Fantom or other.

I took the drive apart. I have installed the drive as the slave drive, but my computer is not seeing it. Is this because the drive is not bootable or because I have not got something configured right in the bios.

Collapse -
As slave on primary?
by R. Proffitt Forum moderator / August 23, 2006 4:30 AM PDT

If so the jumper on today's machines would be on Cable Select and plugged into the middle connection. And a power plug too.

Details matter.

I can't see your BIOS but hopefully it shows there.


Collapse -
any other suggestions
by estcst_kevin / August 23, 2006 7:01 AM PDT
In reply to: As slave on primary?

Ok that was a success, but it now see?s the drive as Local drive D and asks me to format. Same problem I had to start with. mmmnn, this is a tough one!

Collapse -
Don't give up!!!
by R. Proffitt Forum moderator / August 23, 2006 7:05 AM PDT
In reply to: any other suggestions
Collapse -
Nope, not giving up yet
by estcst_kevin / August 23, 2006 8:00 AM PDT
In reply to: Don't give up!!!

I have a couple other things to take care of first [$$$] and some other channels/options I am looking into before I give up. Thanks for all you help and support Bob

Collapse -
check the solution here
by xfrafc / September 7, 2006 3:00 AM PDT
Collapse -
create a partition.... WHAT!!!!
by davemoreton / September 7, 2006 6:34 PM PDT

Don't try and create a partition, if you have any work that you can recover on there at all trying to create a partition will lose everything,

Try the recovery tools Ontrack.

Popular Forums
Computer Newbies 10,686 discussions
Computer Help 54,365 discussions
Laptops 21,181 discussions
Networking & Wireless 16,313 discussions
Phones 17,137 discussions
Security 31,287 discussions
TVs & Home Theaters 22,101 discussions
Windows 7 8,164 discussions
Windows 10 2,657 discussions


Help, my PC with Windows 10 won't shut down properly

Since upgrading to Windows 10 my computer won't shut down properly. I use the menu button shutdown and the screen goes blank, but the system does not fully shut down. The only way to get it to shut down is to hold the physical power button down till it shuts down. Any suggestions?