I would contact your hardware supplier or the manufacturer of the drive.
Could you go to your BIOS settings and "load default"?