Storage forum

General discussion

External hard drive not recognised. Please help :(

by jamhay / May 15, 2005 1:25 AM PDT

I have a 120GB maxtor external harddive hooked up and in use for a while. The drive has already been partitioned and has around 40gb of data stored on it.

My PC went in for a repair and a blanket copy had to be made and reinstalled. The only main difference to the PC was that they installed XP SP2

I'm not sure if this is related to the upgrade but the external hard drive does not apper in "my computer" anymore.

After reading others posts I've checked the device manager and the drive does not appear in their either my C drive show up as being the basic drive.

The only dives that are displayed are...

C - Internal harddrive
E - Internal CD drive
D - Internal DVD drive
G - External DVD drive

The External drive used to be "H" but it doesnt appear now.

The drive did not come with a driver as its plug and play and worked fine when I first installed it this way.

The USB icon appears in my tray when I connect it and states that the device is working properly.

When I click on the USB icon in the tray to stop a device, and then on "mass storage device" in the pop up window, it displays the drive there "eg maxtor 6 USB device, so the pc must recognise it.

can anyone help please, I'm at my wits end...

Discussion is locked
You are posting a reply to: External hard drive not recognised. Please help :(
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: External hard drive not recognised. Please help :(
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
Are you using Explorer?
by R. Proffitt Forum moderator / May 15, 2005 1:38 AM PDT

If so, it can hide drive letters. Look up TWEAKUI and use that to see if drive letters are hidden.


Collapse -
Yes, And I've downloaded and ran TWEAKUI................
by jamhay / May 15, 2005 4:22 AM PDT
Collapse -
Did you ...
by R. Proffitt Forum moderator / May 15, 2005 4:50 AM PDT

Completely shutdown?

That is, shutdown and remove all power from all devices and power bricks for a 10 count and try again?

How about plugging that into another USB port? Some discover some ports will not work, but report "OK".


Collapse -
I've Shutdown & Restarted....
by jamhay / May 15, 2005 6:00 AM PDT
In reply to: Did you ...

Ok Bob,

I completely shutdown and unplugged everything then booted back up.

The external hard drive still doesn't appear in 'my computer'

I have an external DVD drive that shows up, so I swapped the plugs, connecting the external HD to that USB port.

Like the other port, again the PC responds when I connect it,& the 'safely remove icon' appeares in the system tray.

When you click on the 'safely remove icon', it asks if you want to stop the external hard drive so the USB port must be working.

view screenshot -

It does say "location 0" would that have something to do with it?

Collapse -
Looks like...
by R. Proffitt Forum moderator / May 15, 2005 7:03 AM PDT

You need to test the drive on another machine and if it behaves the same, time to call its maker to get it exchanged.

In closing, you may have read my statement about such devices not being a backup system...


Collapse -
Is this problem unique?
by jamhay / May 15, 2005 9:31 AM PDT
In reply to: Looks like...

The drive is only 3 months old, although it does have 90/120GB stored on it.

It seems more of a PC problem than a hard drive problem it would be a shame to format it only to find out the PC still wont read it.

From the info and the screenshots I've given previously would anyone be able to point me in the right direction of a driver download?

I think reinstalling the driver may work?? its worth a try.

is this problem unique to problems you've help with before? It just seems like theres something silly I'm missing out somewhere.........????

Collapse -
Here's the deal. You can't format it since...
by R. Proffitt Forum moderator / May 15, 2005 11:47 AM PDT

It doesn't show in the disk management tool. The problem is not unique. Such devices fail all the time.

Again, such a device is not "backup." Don't entrust what you can't lose to a hard disk.

AND... a test is needed on another PC to call out where the issue is. I know where my bet is.


Collapse -
Having the same problem with SCSI drive...
by dvbauru / May 19, 2005 12:37 PM PDT

I have a Medea external videoraid unit that has strangely *disappeared* from explorer as well, but it shows as working normally in the device mgr. I too don't know what else to try. Can't access the data without the raid controller as it is striped on the two drives.

Collapse -
For raid that data is...
by R. Proffitt Forum moderator / May 19, 2005 9:09 PM PDT

On your backup tape, CD or DVDs.

I'm not kidding.


Collapse -
I am having the same problem...have you sorted out yours?
by rbs100 / November 16, 2005 6:29 PM PST

My 120gb external hard drive works on Windows 98 but not Windows XP SP2. At times the drive gets detected and then suddenly it vanishes. If you have sorted out your problem do please help me out. Thank you!

Collapse -
My SeaGate 320gb Hard drive seems to have power related prob
by subsy1662 / November 9, 2007 5:03 AM PST
In reply to: Did you ...

Hi Bob,

read yourt advice to others and thought you might be able to help with my seagate 320gb...

My laptop, HP, on XP sp2, p4 HT, 1gb ram is not recognising the drive, this seems to be linked to the power light on the drive, connected via usb2.0 cable. Sometimes it is recognised but increasingly it either comes up as drive f, usually its drive f but seagate f, lately its just plain and simple f and when i try to explore it there's nothing, as the laptop tries to interrogate the drive the power light goes out for long periods, and its not done that until this current problem.

Hope that's enough to tempt you to assist, if you need more, please ask and i'll tell all...



Collapse -
Try some of the common cures.
by R. Proffitt Forum moderator / November 9, 2007 5:34 AM PST

A new drive case?

Collapse -
One check did it.
by dalehe / January 27, 2006 5:31 AM PST

TweakUI did have the drive unchecked. Checked and after hours of trying to solve there it was. One click. Amazingly simple.


Collapse -
Where in TweakUI did you find your drives?
by Ginger M / October 12, 2006 10:46 AM PDT
In reply to: One check did it.

I am having the same issue and I just downloaded and searched through TweakUI to do the click thing and I can't find the drives to click or unclick....Help?

Collapse -
This worked for me
by Ruanaidh / October 17, 2006 4:10 PM PDT
In reply to: One check did it.

I am not a Technician. I just played around with the hardware and everything is now working fine.
1/ I turned off my computer at the powerpoint.
2/ I attached the Maxtor II hard-drive to the USB port of the non-powered computer and turned the Maxtor on.
3/ I then turned the computer on at the powerpoint and started it up
4/ Voila! Windows recognised the 'new' hardware and I was off and running.
I can't explain how this worked I just know that it did when all else failed.

Collapse -
I'm having trouble too.
by dizzlledogg / June 25, 2008 3:26 AM PDT
In reply to: This worked for me

Hi! So im having that problem + did what you said, but i can't get the drive to turn on when it's off. i held it for 20 seconds one time. it'll only turn when you log into an account, but the light is on for literally 1 second and goes off. then i see the popup on my desktop that there are no drivers for this. my biggest problem is that this is my dad's 250gb maxtor external hard drive, and i'm screwed if he finds out. if it helps, i was moving my whole itunes library to it, which is over 88 gb, but fir on both drives. then moving it onto a different external hard drive (my 160gb western digital) and then it went downhill about halfway through the second process.any tips?

Collapse -
my WD external hard drive is not being recognized by my pc
by shlomohal / February 17, 2009 12:05 PM PST
In reply to: This worked for me

hi i need help, my externel WD 2 TB hard drive is not being recognized by my computer, and when it does you don't see anything on it, it's empty both the truth is it has about 700 gb on it, and when you check how mutch space it is still available on the hard drive, it is 0 bytes that means when you go to properties the hard drive doesn't have the name on top, and the whole capacity is blue like the hard drive is completly full, but by the used space is written 0 bytes and on free space is written 0 bytes and the capacity is 0 bytes,.
And ones it did came up that the hard drive has used space 700 gb, and ones the hard opend for like 2-3 minutes and than it closed again and than the pc will not recognize the externel hard, till i plug out the power from the hard drive wait a couple of minutes and than whan i plug it beck in it will recogineze it for about five minutes, both when i open it it is empty, both i know that it is not empty becouse it recognized it ones for 2 minutes and i saw that the info is still in their, I tryed changing the usb port it didn't help, booting the pc, uninstalling the hub and reinstall it, power out power on, again changing pc, so if somebody could help me out please do thanks

Collapse -
WD external hard drive not recognized by laptop
by im_patient / March 23, 2009 12:27 AM PDT

Thanks shlomohal for posting this. I would have said the same thing. Only difference is that I have a 320GB WD Passport which holds about 300GB of data.

Before this happened, I plugged my WD into the USB port. Then I clicked and dragged one file (mp3) onto the Windows Media Player. Then my laptop froze. All open applications went "Not responding". I clicked on the 'Safely Remove Hardware' icon, but nothing happened. After about 20 minutes, I pulled the USB cable, then restarted my computer. After that, I pretty much experienced what you explained. A few hours later, I could still see my files, but cannot use any file. But now (4th day) my WD just doesn't appear when I plug it in.


Collapse -
issue with samsung 1TB hdd in a usb 2.0 HDD external box
by adhdam / August 9, 2009 4:40 PM PDT
In reply to: This worked for me

When i originally hooked up my HDD it worked, but after a few hours it stopped working, it is seen in my device manager as fine, but not viewable in the disk management, and i can see it in my computer but it will not allow me to create anything on the drive, it says something about file not specified. this is on an XP machine where i already have a WD 500GB HDD working fine attached via usb also, i have hooked it to my vista machine and it worked fine, but when i bring it back to my XP machine nothing, now i have tried reformatting with vista, have uninstalled all my usb ports and also reinstalled my chipset, anyone have any other ideas of what i can try. my last resort will be to install it into my machine and give up on the external case but this will defeat the purpose of why i purchased it, please help Sad

Collapse -
Read this discussion and consider.
by R. Proffitt Forum moderator / August 9, 2009 9:23 PM PDT

All the great ideas are here. Also you buried your plea for help.

Collapse -
Update on my recent 'fix'
by Ruanaidh / October 17, 2006 5:26 PM PDT
In reply to: One check did it.

I disconnected the Maxtor and tried it again and it failed to work. So in the meantime I found an alternative power supply lead, plugged it into the maxtor and it is now being recognised by windows. It would seem that in my circumstance the problem was power related. Good Luck

Collapse -
I've just had the same problem, and here's what it was:!!
by obsessed / May 19, 2005 11:27 PM PDT

Sometimes, the external encasement connections fail. I had an external drive that suddenly lost connection and wasn't recognized by My Computer or the Disk Management. I purchased a new external case, took out the hard drive and connected it to the new case, and voila! Instant recognition, and my 100G of data was still there and safe. I have a question for Bob, if you're still following this! Bob, how DO you suggest to backup if you say that hard drives are a bad idea? I have had just as many problems with DVDs that "fail" and suddenly lose data. I have followed discussions about this as well, data that people thought were on their DVDs "forever" and suddenly all is lost, or the drive won't read the DVD, etc. Is there a REAL backup solution?

Collapse -
Bob's backup.
by R. Proffitt Forum moderator / May 19, 2005 11:42 PM PDT

I have many levels of backup. Sadly it does take time to do this so I fit it inbetween and as part of my PC usage.

1. CDRW/DVDRW disks contain a set of what I need to move to a new machine. NO OS or applications are needed since I have the install CDs plus those have a copy.

A total of 3 sets are rotated and as some media fails, it gets replaced. This is cheap compared to just a few years ago.

2. Next in line is an USB hard disk. Nice for quick backups that I don't want or need to refresh that DVDRW set (I used to use CDRW, but DVDRW is just so many less disks.)

3. A smaller set of files is sent off to my mini-server that is running OpenSSH or a secure shell server. This contains my core works that I can't lose and photos.

4. Further down the list are my set of OS CDs, applications CDs. All the originals and CDKEYS are in a package far away from the computers. A copy of these are in my recovery kit. I use my recovery kit first and if one of these CDRs fail, I can go get the original to duplicate it again and refresh the recovery. This happened once so the system works.

5. The take it with me plan. I recently acquired an 1 GB USB memory key. On it are the items that I don't want to lose if I was away from home and the home vanished. While I can't carry my photos there, key works and such are on it.

Some may consider this extreme but they may not have suffered a total wipeout yet. Or watched others lose it all.


Collapse -
Bob's Backup
by norrtalje19 / January 20, 2006 7:35 AM PST
In reply to: Bob's backup.


Very nice setup.

I have somewhat of the same approach, but do not use any "plastic" media, only hard drives.

Have 2x250 GB drives inside PC case for quick and dirty backups (no mirroring but use SyncToy to backup everything that is important - inclusing all written down "keys" in Excel sheets). Will soon add another 300GB drive and make these 2x250 drives as a RAID I.

All this data is mirrored about once a week onto my wife's computer, in a different room, where it lands onto her D-drive (2nd disk).

Outside of this, we have 2x80 GB USB drives that are stored in the basement and one 120GB hard drive that is stored at the bank in a safe deposit box. About once every month, that drive is taken home to be "re-freshed".
Is this anal? Possibly so, but I did have a hard drive crash (on a laptop) in 2004 and after that I rather go a bit too far since storage today is cheap.

Microsoft's SyncToy is also a pretty handy and fast tool for setting up small backup routines. And, it's free!

Collapse -
Can't recognize an external USB hard drive--a solution
by jmmd / August 28, 2005 5:21 AM PDT

Had the same problem with a generic USB drive case from TigerDirect with an old WD hard drive inside it. It was being recognized only intermittently which was making me crazy. Some days XP saw it, some days no.

Removing the USB connector from the USB hub, and then putting it into a new different port on the hub did not help the computer recognize the external USB drive.

But disconnecting the external drive from its power supply, and then disconnecting and reconnecting the USB cable at the external drive (with the computer on) led to XP SP2 seeing it and assigning a drive letter in Explorer. I don?t remember if I reconnected the power supply or the USB cable at the external drive first, but it was nice to see it back in action.

Collapse -
This worked for me too.
by catbait1 / August 26, 2007 4:13 PM PDT

Wow, I'd tried about everything and then used your sequence. Essentially, turn off case, disconnect P/S and disconnect USB cable. I then plugged in USB cable, plugged power supply back into the back of the enclosure, turned it on and my computer found it. As usual, it was on my network "F" drive, but that was an easy drive letter change.

Collapse -
Same issue with SP 2
by abeers / September 13, 2005 3:45 AM PDT

I am having the same problem with a LaCie 250 gig drive. It does seem to be related to SP2.

Just to take this to another level of weirdness, Mac OSX mounts this same drive and regognizes the files eventhough it can't do anything with them as they were written on a Windows PC

Collapse -
same issue with Firewire drive
by crontegy / September 17, 2005 3:24 AM PDT

i can't see it but when i restart the red light flashes like its trying to do something but nothing happens. i have a feeling its case and i have 2 of them so i am probably going switch them and see if it works. who knows tho. will the red light flash if its the case?

any help much appreciated.

running XP

Collapse -
The lesson I learned.
by R. Proffitt Forum moderator / September 17, 2005 4:01 AM PDT

Use USB 2.0 on the PC and Firewire on the Apple for hard disks. It's a small lesson, but so far the lesson seems to be repeating too often.

And yes, it should work but after dozens of failures why should I try to fix an apparent industry issue?


Collapse -
Any fixes to the problem then?
by englishinvader / December 3, 2005 12:52 PM PST

I have the same problem with my external HD, and after reading through this thread I've not seen a solution so far.

My external HD is recognised and listed in My Computer intermitently and rarely seems to work long enough to transfer a file of more than a few Mb's. It does work on a PowerBook/OS X so I figure the External HD Enclosure or the HDD is not at fault (though the sound the HD makes sometimes when it's not working you'd think it was knackered).

If it's SP2 that's got issues, does anyone know of a patch or something to fix this?


Popular Forums
Computer Newbies 10,686 discussions
Computer Help 54,365 discussions
Laptops 21,181 discussions
Networking & Wireless 16,313 discussions
Phones 17,137 discussions
Security 31,287 discussions
TVs & Home Theaters 22,101 discussions
Windows 7 8,164 discussions
Windows 10 2,657 discussions


Help, my PC with Windows 10 won't shut down properly

Since upgrading to Windows 10 my computer won't shut down properly. I use the menu button shutdown and the screen goes blank, but the system does not fully shut down. The only way to get it to shut down is to hold the physical power button down till it shuts down. Any suggestions?