Don't worry, you won't need 10. Firefox and IE are enough. Use Firefox for everything except what it won't work with, because of Active X, sloppy code, or whatever.