Resolved Question

Explorer stops responding when accessing USB drive on router

Mar 22, 2020 6:27AM PDT

I have a usb hard drive attached to my Netgear XR500 router. All computers on the network (some WiFI, some Ethernet) are able to access that drive except one (a WiFi one). It is a W10-32 tablet/computer running in desktop mode. It has worked in the past. With Explorer, if I try to access that drive, files and folders list in the tree and many, but not all favorite icons populate. If I click on anything .. file or folder, Explorer stops responding. Any help would be appreciated in advance.

Discussion is locked

WacoJohn has chosen the best answer to their question. View answer
Answer
Follow
Reply to: Explorer stops responding when accessing USB drive on router
PLEASE NOTE: Do not post advertisements, offensive materials, profanity, or personal attacks. Please remember to be considerate of other members. If you are new to the CNET Forums, please read our CNET Forums FAQ. All submitted content is subject to our Terms of Use.
Reporting: Explorer stops responding when accessing USB drive on router
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Comments

Best Answer

- Collapse -
PS. THE TEST.
Mar 22, 2020 11:44AM PDT

Does this happen when you plug said drive into said laptop? If it does, and there is nothing new on the stick (new files could lock up Explorer which is a rather long discussion on its own) then the factory reset is even more called for.

- Collapse -
Thank you all
Mar 22, 2020 11:52AM PDT

for the info and suggestions. Based on that, I suspect it has to do with the size of the drive and the number of files on it. I will try a much smaller drive on the router and see if the problem resolves.

- Collapse -
I have to disagree.
Mar 22, 2020 1:16PM PDT

For decades I've been able to lock up Windows and Windows Explorer with some files. My story is from the 90's where I had a CD and a file that would cause Windows to lock up when.
1. You would insert this particular CD.
2. You would copy the file to the Windows desktop.
3. Use Windows File Explorer to look at the CD with said file.

I was at the time working with an OEM and lucked into a trip to Microsoft in Richmond, WA. I took these items with me.

I waited in line to talk to Microsoft engineers which was an amazing opportunity. I explained what I had and offered the items to them. Their answers taught me so much about Microsoft that day. Ready? Microsoft engineers said "Don't do that."

So there it is. It doesn't matter how big that drive is. It matters what is on it.

-> Since this is just one PC that is acting up, and it's one of those type PCs (32GB storage) a factory reset is best.

Post was last edited on March 22, 2020 1:41 PM PDT

- Collapse -
Answer
You say
Mar 22, 2020 9:30AM PDT

You write that it's just this PC. Given the story I think this is one of those rather awful W10 32GB drive models. Try a factory reset to get it back to when it worked.

- Collapse -
USB drive on router
Mar 22, 2020 9:48AM PDT

Not sure I understand what you mean (this is one of those rather awful W10 32GB drive models.).

The HD on the router is an 8TB drive by Western Digital. By factory reset, do you mean completely reset the tablet to factory?? I have tried that in the past, but am willing to try it again if that is what you mean.

- Collapse -
Re: W10 32 GB
Mar 22, 2020 11:34AM PDT

That's exactly what Proffitt means. Those Windows 10 machines with 32 GB storage space are awful to maintain. I'd say 64 GB is a reasonable minimum.
Try a reset to factory settings. Then it's quite possible it works OK for some time.

Post was last edited on March 22, 2020 11:36 AM PDT

CNET Forums

Forum Info