Windows Legacy OS forum

General discussion

.exe .lnk & .reg association broken

by Ent0x / December 19, 2004 6:25 AM PST

When I want to open one of this extentions (.lnk, .exe,.bat,.reg..) windows XP wants me to choose wich program i use for them (sry english very poor)..
I found this
but the problem is that if i try to download and open one of them fix, for exemple the .reg fix, it s also a .reg file, and i can t open it.
Can you help me ?
(I also tried a scan disk & antivirus but didn t help.)

Discussion is locked
You are posting a reply to: .exe .lnk & .reg association broken
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: .exe .lnk & .reg association broken
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
by MarkFlax Forum moderator / December 19, 2004 8:00 AM PST
Collapse -
Oh boy...
by SylentStar / December 19, 2004 8:23 AM PST
In reply to: Entox

I suppose that you use XP.

I suggest a fix, not sure about the result because I never tested it
myself with a REAL problem like yours.
It is necessary to restore the .reg file broken association first.

You already have the .reg fix. Put it on your desktop, and rename the .reg
file to : 1.reg, simple as that.
Click on Start, Programs, Accessories, COMMAND PROMPT.
A black box appears, with a blinking cursor.
Write: CD\
Click on Enter.
Click on Enter.
Click on Enter.
Write: REGEDIT.COM 1.reg
Click on Enter.

You're supposed to see now: Are you sure you want to add the information in 1.reg
to the registry?

Answer "YES."
Reboot after.
The .reg association is maybe restored.
Check yourself.

Collapse -
Here's another possible solution
by Tufenuf / December 19, 2004 8:54 AM PST

Go to the link below and download the Fixswen.inf Tool
"Save the fixswen.inf file to your local hard disk, right-click on the file and choose install".

"A Setup INF file to undo registry changes made by W32/Swen@MM and other threats that prevent REGEDIT, BAT, COM, EXE, PIF, REG and SCR files from running".

It may get baqck the .reg file association as well as some others. If it doesn't get back all of them but does get back the .reg file association you could go back to the dougnox ste and get the appropriate fixes. If you can't access the Intenet on the problem computer use anothe computer yo download it on a floppy or CD then transfer the floppy or CD to the problem computer and run it.

Good Luck,

Collapse -
Omg !
by Ent0x / December 19, 2004 6:00 PM PST

Thx for your answer but.. no ones worked:
=> When i tried to backup, i had to go directly in regedit, and i can t because of my .exe "non-association"
=> I can't go on COMMAND PROMPT also because of the same probleme. (its a .lnk association :'()
=> And when i tried to install the INF file to undo registry changes made by W32/Swen@MM and other threats that prevent REGEDIT, BAT, COM, EXE, PIF, REG and SCR files from running, he also bloqued me by opening an .Exe program.. "grpconv.exe"

Collapse -
Found a clue
by SylentStar / December 19, 2004 9:04 PM PST
In reply to: Omg !

Start in "Safe Mode with Command Prompt"
Usually, you reboot then Press F8

Read here: Kelly's fix worked! It didnt work in normal mode, so I switched to safe mode with command prompt and typed in "regedit -s "C:\path of the file\linkrestore.reg" and it worked. Thank you Chuck 2 and Tufenuf for your help.

You need to type the exact command at the prompt. With quotes or without, I don't know.
Maybe someone else will help and show us how.

Personally, in a situation like that, I prefer to insert the XP boot disk, format and start a new life if I have nothing to lose.
I'm afraid of the "Beast", hidden somewhere on your drive.

Collapse -
Did you try System Restore in SAFE mode
by Tufenuf / December 19, 2004 9:26 PM PST
In reply to: Omg !

Ent0x, Try starting your computer in SAFE mode then try a System Restore using a date prior to when this whole mess started. It's worth a shot.


Popular Forums
Computer Help 51,912 discussions
Computer Newbies 10,498 discussions
Laptops 20,411 discussions
Security 30,882 discussions
TVs & Home Theaters 21,253 discussions
Windows 10 1,672 discussions
Phones 16,494 discussions
Windows 7 7,855 discussions
Networking & Wireless 15,504 discussions


Samsung Galaxy S8's major makeover

This year's flagship phone gets a sexy new design and Bixby, a house-made digital assistant.