Windows Legacy OS forum

General discussion

exe files will not run

by galadriel2x / September 8, 2007 3:34 AM PDT

Hi all of a sudden any exe files i click on do NOTHING!!! I get no error message or anything. I have clicked on just about all of my past downloaded exe files that are on my pc and tried downloading others and saving them but none of them will run. I double click but them but NOTHING. If I run when I download an exe file instead of saving it first, it runs just fine, it is only exe files saved onto my pc that will not run. I have checked for the w32Sircam virus and my pc does not have it. I have run adaware and virus check and both are clean. Does anyone have any ide why this might be happening please? Many thanks

Discussion is locked
You are posting a reply to: exe files will not run
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: exe files will not run
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
Could be the old EXE association issue. Link to fix.
by R. Proffitt Forum moderator / September 8, 2007 3:57 AM PDT
In reply to: exe files will not run
Collapse -
does not work
by galadriel2x / September 9, 2007 4:39 PM PDT

Hi, I downloaded the fix and ran it, but still get nothing when click exe file. The window bar at the top of the folder flashes as if it is trying to do something, but then stops and nothing else happens. Thanks for the reply

Collapse -
.exe association fix.
by ZARTT / June 13, 2011 4:03 AM PDT
I went to the site on my wife's P/C, downloaded the .exe registry value, and stored it on our NAS drive.
Since I couldn't open Windows Explorer on my P/C (.exe file) I was able to open the NAS drive using the My Computer function.
I navigated to the registry key, unzipped it, and loaded it onto my P/C.
The .exe problem was fixed immediately.
This problem was a leftover from a virus/malware trojan called "XP Home Security 2012"
Beware of that one, it is nasty.
Collapse -
Thank you
by oformu / June 16, 2011 1:18 PM PDT
In reply to: .exe association fix.

Thank you for notifying about that virus. Maybe to use some antivirus next time. Basically companies are dealing with those kinds of issues so you can do some other stuff and its not needed then to run regedit etc.
But anyway thanks for notifying. I use Bitdefender for now and its quite good but its not the fastest. But nor the Norton or something similar is fast to be honest. You will need some good machine for it.

Collapse -
Probably Worth a Order: Sys Restore, SFC, ...
by tobeach / September 9, 2007 5:23 PM PDT
In reply to: exe files will not run

or checkdisk /R. Last 2 can be operated from My Computer>C: or other w/OS on it> Properties>Tools>Error Checking>Check Now> either or both boxes.
Try to recover damaged areas will take about 1 hour in normal mode , considerably longer if launched from Safe Mode. SFC only is fairly quick. Maybe you'll get lucky!! Happy

Collapse -
seem to have solved problem (I hope)
by galadriel2x / September 9, 2007 5:35 PM PDT

Hi a friend of mine sent me this to have a look at:-

Look like you're missing these two...for your open and runas commands...notice the \ on either side in this as opposed to yours...

@="\"%1\" %*"

@="\"%1\" %*"

If you want to try it - or wait till after hours - navigate to those in the registry (Start->Run->Regedit)

and you want to alter the Default value (that's what the @ points to).

I'm 99% certain it wouldn't effect anything (thus I'll leave it up to you to decide on that last 1% :).

Basically this is necessary to encapsulate the path\file of your executables in quotes so that it can take into account the paths/files with spaces in the name.

Can you do
or copy an exe to the root of the drive and run it? That would confirm the above is the problem..

I checked my Reg values and altered them to the same as above and my exe files are now opening. I presume my registry must have become corrupted at some point??
Thankyou very much both for your help. Your time and effort is very much appreciated.Best wishes

Collapse -
NO it didnt help!
by galadriel2x / September 9, 2007 6:11 PM PDT

After doing the above and restarting I discovered I couldnt open program files even though I could now open exe files saved to my pc!!! I changed the values back to the original but noticed that the end set of parenthesis were missing in my registry entry so added them. Ican now open programs and exe files, but am getting access denied on regedit / run!! I am going to run the repair and see if it helps at all. If not then I will come back again for any further suggestions. Thanks

Collapse -
still stuck!
by galadriel2x / September 9, 2007 7:41 PM PDT
In reply to: NO it didnt help!

Okay, I ran chkdsk, it did nothing. I tried system restore way back, but did nothing. After adding the " to the end of the values in regedit, I could open both programs and exe files on the PC, however got error messages when I tried to use run for anything (first was asked if wanted to add to registry and then message saying disk error). so I have restored my reg values back to original "%1" %*
and I am now back to square one!! everything works normally except I cannot open any exe files. I ran the regfix in the first post, but it did nothing. Many thanks

Collapse -
Re: still stuck!
by Tufenuf / September 9, 2007 8:58 PM PDT
In reply to: still stuck!

galadriel2x, Go to the link below and scroll down to line 12 (left column) and click on "EXE (lnk and regfile) Fix for Windows XP" to download a reg file fix. Save the REG File to your hard disk. Double click it and answer yes to the import prompt.

You may also want to try the free tool called "Remove Restrictions Tool (RRT)" which is available at the link below.

Your problem may very well be virus/malware related. Update your virus definitions and run a full virus scan and also run Ad-aware or similar spyware programs.


Collapse -
already done this
by galadriel2x / September 9, 2007 11:02 PM PDT
In reply to: Re: still stuck!

Hi Tefenuf, The first answer I received already gave me a download link for a reg file fix which I used and it did not help. I already did a full virus scan and adaware removal before posting. I ran the reg fix file you recommended but still it did not help. The problem with downloading and using the RRT in safe mode is that it is an exe file and my whole problem is that I cannot run exe files at the moment unless I run them instead of saving them. I cant do that if I need to run it in safe mode. Thanks for the help. Any other suggestions gratefully received.

Collapse -
windows repair
by galadriel2x / September 9, 2007 11:08 PM PDT
In reply to: already done this

Someone has suggested I try a windows repair with the winxp disk. If I do this, do I lose any applications, data, files etc, or does my PC stay as it is apart from the reg repair please? (also is this likely to work?) Many thanks

Collapse -
no answer!
by galadriel2x / September 12, 2007 9:06 PM PDT
In reply to: windows repair

I didnt get any answers to my last question, so I went ahead and tried it anyway. It appears to have worked for now at least. Thanks for replies received. Best wishes

Collapse -
Same thing
by javagrinder / September 18, 2007 4:45 PM PDT
In reply to: no answer!

Ok,this happened to me about 3 weeks ago. And at this stage I think i tried everything i can think of.
SOME programs just don't start,blink for a second and that's it.If repair the installation or do reinstall it works but after closing same thing happens again. Only clue that sometime prior i installed .NET2 and at some point msxml installation had to be repeated.
1)Ran - McAffee stinger, adaware,went through hijackthis-log,turned off DPE,uninstalled ZoneAlarm.
2)checked exefile values
3)Updated Nvidia drivers,removed epson and hp drivers.
4)updated msxml,it was failing, re-tried a couple of times, found some solution about using gupdate this and
5)nvidia gave me a freezing desktop (massacred registry,regarding permissions,etc - reinstalled SP2 instead of the original disk(coz last time i did that i eventually ended up reinstalling the whole lot).
6)got shexview.exe, checked if there are any hooks conflicting or something at some point pretty much disabled everything.
7)found somewhere that Java 6.2 can cause something similar and that installshield depends on that, re-installed that and .NET2 for a laugh as well.

Still nothing.

I am kind off running out of ideas,bu t i'm coinvinced and don't know why, that the problem has something to do with installer.

If someone could throw a suggestion at me, I am all ears.

Popular Forums
Computer Help 51,912 discussions
Computer Newbies 10,498 discussions
Laptops 20,411 discussions
Security 30,882 discussions
TVs & Home Theaters 21,253 discussions
Windows 10 1,672 discussions
Phones 16,494 discussions
Windows 7 7,855 discussions
Networking & Wireless 15,504 discussions


Meet the drop-resistant Moto Z2 Force

The Moto Z2 Force is really thin, with a fast processor and great battery life. It can survive drops without shattering.