Thank you for being a valued part of the CNET community. As of December 1, 2020, the forums are in read-only format. In early 2021, CNET Forums will no longer be available. We are grateful for the participation and advice you have provided to one another over the years.

Thanks,

CNET Support

General discussion

Excel not copying formulas

Feb 12, 2009 6:26AM PST

I had a problem today with Excel 2003(Win XP)not copying formulas. When I copied and pasted, I would get the results of the formula as it/they existed in the original cell(s) rather than the formula(s). I reloaded Excel at one point and that seemed to clear things up, but when I loaded a second workbook it repeated the non-copying behavior for the second....when I closed out of the second workbook, it behaved properly with the first workbook???

Does anyone have any idea what is going on? The Excel program has been on the computer for a long time..perhaps it's corrupted in some fashion?

Thanks, Bruce

Discussion is locked

- Collapse -
Strange. Nveer seen it.
Feb 12, 2009 4:00PM PST

So just a few questions.

- You just do ctrl-c on the old cell and ctrl-v on the new cell?
- Does it work correctly in all NEW workbooks and incorrectly in (some) OLD ones? Or isn't it as simple as that?
- If you try Edit>Paste Special and choose 'formulas' or 'all', does it work?

Kees

- Collapse -
Thanks...
Feb 13, 2009 10:19PM PST

...just plain old cut and paste. The workbooks were old...likely created under an older version of Excel. I've just finished a fairly large new workbook with no problems. I'll try the paste special/formulas/all next time it acts up. The sheets are related to income tax so there will be plenty of opportunity for the problem to reoccur in the next few weeks.

Bruce

- Collapse -
I'm having the same issue in Excel -- just started happening
Apr 22, 2012 12:19AM PDT

Did you figure out the solution to your Excel problem with cutting and pasting? I have Excel 2003 and no matter what I do, if I hit Ctrl-C and Ctrl-V (or Cut and Paste from the menu), it always pastes the VALUE and not the formula.

- Collapse -
I'm having the same problem
Apr 26, 2012 3:39PM PDT

In one spreadsheet, I do a copy (^C) of one cell containing a formula, and go to another cell, and do a paste (^V) and it copies the result of the formula calculation in the first cell, not the formula, which is the normal behavior. It's driving me nuts.

It's a big spreadsheet with a lot of forulas and a lot of sheets, so it would be very time-consuming to try to re-create it, to see if that solves the problem.

What's going on? HELP!

- Collapse -
Problem solved!
Apr 26, 2012 11:06PM PDT

After some additional research into this, apparently this will happen if you have Firefox (perhaps with the Skype plugin installed) running at the same time that you have Excel running. If you close Firefox, you will see that the cut and paste functionality works as it should!

Crazy!!

Joe P.

- Collapse -
Excel problem still persists!
Apr 27, 2012 5:38AM PDT

Thanks. Interesting theory. I was excited for a minute. I do have Firefox, and I believe it has the Skype plugin. But it's not running right now, and I tried the Excel spreadsheet again. But, same thing!

Any other ideas?

Mike

- Collapse -
Excel Problem
Apr 30, 2012 12:24AM PDT

I am having the same issue! I cannot cut and paste formulas or copy worksheets as I did in the past. I do not have Firefox, but do have Skype. Thoughts??

Pam H.

- Collapse -
Excel Copy & Paste not working for me either!
Jun 6, 2012 12:44PM PDT

Hi Mike,

Have you resolved this issue yet?? I'm having the same problem.... I'm not using Firefox - I use Google Chrome, (have recently changed from Internet Explorer to that). I also have Skype so maybe have that Skype Plug-in problem but have no idea how to find out...!!!

I use spreadsheets on a daily basis with formulas and I have been finding that instead of copying and pasting a formula, I have to type it in every cell because the copy and paste only pastes the value as a constant. When I do a copy and paste special, I get a weird screen that asks about the Source, and I can select Unicode text or text!!

If you have a solution, please let me know as this is driving me nuts too!! Happy

Jo

- Collapse -
SORTED!!!
Jun 6, 2012 2:36PM PDT

This issue has been sorted now! It was being caused by Skype click to call, for some weird reason. So I just un-installed the programme and started up Excel again and it was all back to normal! Yay!

- Collapse -
Gmail Voicemail
Jan 2, 2013 1:06AM PST

I installed Gmail's voice mail, and this happened to me as well. Drove me nuts because some force of evil wasn't letting me uninstall the Gmail voicemail. I finally had to view hidden files, and "View Protected Operating System Files" with a lot of DON'T DO THAT WARNINGS, but that was the only was to delete the file.

At least I hope it worked. The situation was solved on Monday, but I haven't been in Excel today.

Anyway - it was a ridiculous waste of time, even though it apparently solved the problem in the end.

- Collapse -
Try this....
Jan 22, 2016 11:55PM PST

Try going to File...Options. Under the "Formula" tab ensure the "Workbook Calculation" is set to "Automatic" and not "Manual"

- Collapse -
This worked.
Mar 7, 2016 7:44PM PST

Suddenly, I was unable to copy a simple formula to other cells. I changed the workbook calculation to Automatic and it worked. Thanks.

- Collapse -
Thank you - worked!!
Apr 26, 2016 1:46PM PDT

YES! That was the problem I had, thank you so much! It's a big spreadsheet, so I forgot that I had set the calculation option to manual.

- Collapse -
Thanks
Oct 25, 2016 11:25PM PDT

It worked ..