There should be another option on that same screen: a button labeled "browse ...". Then find Excel. Don't forget to check the "Always use this program" checkbox or you'll have to do every time.

Kees