General discussion

Ethernet broken but Wi-Fi works.

Pretty stumped on this one.

Router: TP-Link Archer C9 (default)/ Netgear (test purposes)/ Airport Extreme (replacement)

Mac Mini: 2014

PC: Old Gateway I don't use much running Windows 7.


I came home to find the internet was down due to the Internet light on the router being orange instead of blue. I rebooted it and the problem persisted so I rebooted it and the cable modem but still no connections. I dug into the routers settings to find under "Internet" all the IP address were blank but the DNS settings would show IP address.

I was able to connect via Wi-Fi and came back to examine the issue further and discovered that under the choices for MAC address that if I cloned my Mac Minis IP I could get online via ethernet.

I only mention my PC because while working on the issue I noticed it was on and that it had blue screened and was doing a dump. I must of left it on the previous night while it was running it's virus update and didn't set it to turn itself off.

So today's my day off and I discovered that none of my devices (Apple TV, Tivo Roamio etc) that connect via ethernet will do so with the exception of my PC. They all claim there is a ethernet plugged in but when I force a connection they claim theres no cable or it just can't connect.

I've restore factory settings on the Archer C9 router but the problem persists. I called my ISP and I'm getting a signal. I can plug the cable modem right into the Mac Mini and I'm good to go.

I then set up my old Netgear router and I'm getting the same results when I run the ethernet cable out of it. The same 'Internet' address read as blanks while the DNS shows actual IP numbers. I was able to play with the MAC address options just like the on the TP-Link and got the same options expect it pulled up a MAC address in the custom field which worked. The Archer wouldn't accept any custom ones I entered. That seemed good expect that the old modem was replaced because it would stop working which is what happened shortly after finding this short term fix.

I went back into the Archer C9 and started looking more into the ISPV6 settings to see if maybe that was part of the problem but I must of changed something I wasn't aware of because it as I reset it back it kicked me out and I can't get back in.

So after googling that and coming up with no way into it I made a run to Best Buy and picked up an Airport Extreme. Now it does detect that I have an internet connection but the ethernet still isn't working on anything. Wi-Fi works all around.

I have found that the ethernet port shows as Self Assigned IP. No internet connection via it but if I turn on and connect via Wi-Fi under Airport Utility it gives me the option to connect to Ethernet which shows an IP and says I'm connected. If I turn off Wi-Fi then the option goes away.


So I'm baffled as to what is causing the ethernet not work on three separate routers and I haven't found anything online that matches with my issue. Any ideas or thoughts?

Discussion is locked
Follow
Reply to: Ethernet broken but Wi-Fi works.
PLEASE NOTE: Do not post advertisements, offensive materials, profanity, or personal attacks. Please remember to be considerate of other members. If you are new to the CNET Forums, please read our CNET Forums FAQ. All submitted content is subject to our Terms of Use.
Reporting: Ethernet broken but Wi-Fi works.
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Comments
- Collapse -
When I see that

For desktops I install a new card and for laptops I go get the USB to Ethernet adapter.

Your post is rather long so I can't guess if you left the WiFi on while using the Ethernet or hard assigned the IP anywhere.

- Collapse -
Shorter

Yeah it's long but I didn't want to leave any info that might help shed light on this.

Short of it is that I can connect via Wi-Fi but not through ethernet on three different routers. On the routers the Internet shows nothing for IP's but the LAN does.

Originally my Mac and PC were ethernet only. I only used Wi-Fi on them when the ethernet stopped working.

Right now the Mac only gets the Wi-Fi signal expect in Airport Utility though it shows that while connected to Wi-Fi the ethernet option starts working. Turn off the Wi-Fi and it stops.

- Collapse -
So this sounds like...

"while connected to Wi-Fi the ethernet option starts working. Turn off the Wi-Fi and it stops."

This sounds like the ethernet or wifi has something other than DHCP for both. If this was on Windows I'd do the net command to reset the stack (see google) and then possibly remove the device in device manager if the net reset failed.

It still could be hardware. Hardware is cheap compared to shop time.

Last idea? Malware. I've seen strange things like that.

- Collapse -
No Default Gateway

Ipconfig shows that there's no Default Gateway
Replaced the Ethernet cable connecting the modem to the router and still no Default Gateway.
.

- Collapse -
Good find.

The DHCP server would need checking but there is malware that hijacks IP settings. And then we have expired antivirus suites that can cause this.

I don't have enough detail in your post to avoid advising a restore to the factory issues OS yet.

- Collapse -
Fixed

So after releasing and renewing via ipconfig with the modem plugged directly to the computer I would get the default gateway info, ethernet listed as enabled and it would work until I ran it through the router and that put me back to no default gateway but the ethernet listed as enabled.

Decided to reset the new Airport router just to do it and at setup it showed the the WAN was off. Checked the box and forced it to setup via ethernet and it worked. Even swapped out the other modems and they now work. No idea what happened or why.

CNET Forums