Question

Establishing secure connection

About the time I switched ISPs and upgraded to the newest Windows 10 I began having problems logging on to web sites. The message 'Establishing secure connection' shows at the bottom of the screen (using Chrome) for several seconds. How do I figure out what's causing this? And fix it?

Thanks,
Pete

Discussion is locked

Follow
Reply to: Establishing secure connection
PLEASE NOTE: Do not post advertisements, offensive materials, profanity, or personal attacks. Please remember to be considerate of other members. If you are new to the CNET Forums, please read our CNET Forums FAQ. All submitted content is subject to our Terms of Use.
Reporting: Establishing secure connection
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Comments
- Collapse -
Clarification Request
There are many priors on this.

Try it with Firefox and other browsers.

- Collapse -
My most typical finding.

The OS is out of date or the date/time is wrong on the PC.

- Collapse -
Perfect solution

Additional to this, we need to clear our browser cookies.
Thank you so much, My mind was going crazy and you solve it in 5 words. Happy

- Collapse -
Answer
secure connection

That message applies to https:// connects usually, such as SSL or increasingly TLS handshakes between your computer and a website. Check security settings in your browsers. Check firewall settings to be sure SSL and TLS aren't turned off. Check router settings also for same. Try a different DNS, but set it in the router since ISP now control the routers they supply more than in past. Verizon can even tell you your password and the security settings even though you set them up and never reported it to them. New spyware in their ActionTec routers now. You can use a free DNS or google's (8.8.8.Cool and secondary google (8.8.4.4)

- Collapse -
Stuck at Establishing secure connection

Many solutions have been mentioned. I had tried out most of them like - forcing TLS v1.1 or above, checking the certificates, re-installing browsers, trying different browsers, etc. In my case, I used Wireshark as a debugger. Some of the packets were flagged as "segment not captured" -- all these had a length larger than the others. I narrowed to the MTU (Maximum Transmission Unit). Used cmd (in admin mode) to run the command "netsh interface ipv4 show subinterface". The interface MTU was 1400. A high MTU can cause fragmentation and could cause the SSL connection to fail. Set the MTU to 576 (the typical default for Internet) using the command "netsh interface ipv4 set subinterface "Local Area Connection" mtu=576 store=persistent. The SSL handshakes went through fine and the sites loaded ok. I tested with a higher MTU of 1300. That's the max value that I could get through my ISP. You could try this approach.

CNET Forums

Forum Info