PC Applications forum

Question

ESET uninstall failure/eelam.sys missing or corrupted

I tried to uninstall Eset via Ccleaner. I got some errors saying something about not having access to a key or something. I clicked ignore and it seemed like the eset got uninstalled. The entry isn't in ccleaner anymore, the eset folder has gone from the ProgramFiles folder and it doesn't run on start up anymore.

The fact is that when I try to reinstall eset, it says that I already have the latest version installed. The most frightening thing is that after "unistall", when I restarted my PC, it stuck on an autorepair loop. I solved this by disabling early launch anti-malware protection from startup settings and by turning off the auto repair.

The problem is that when I try to enter safe mode I get an error that says something like this: "Your computer/device needs repair. Operating System couldn't load, because a critical system file is missing or is corrupted. File: \Windows\system32\DRIVERS\eelam.sys. Error code: 0x000000f."
Please mind that it doesn't mension any drive letter and in my C: drive in its system32 folder there isn't and "DRIVERS" folder, there is only a "drivers" folder with no such file as eelam.sys

Excuse my English. Thank you in advance.

Discussion is locked
You are posting a reply to: ESET uninstall failure/eelam.sys missing or corrupted
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: ESET uninstall failure/eelam.sys missing or corrupted
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.

All Answers

Collapse -
Answer
Next up. ESET's removal tool.

In reply to: ESET uninstall failure/eelam.sys missing or corrupted

Collapse -
ESET's removal tool fails.

In reply to: Next up. ESET's removal tool.

I tried this, but needs safe mode. As I said I cant boot in safe mode.

Collapse -
Eset has a forum just for their product.

In reply to: ESET's removal tool fails.

Collapse -
Re: safe mode

In reply to: ESET's removal tool fails.

Apparently, eelam.sys is a file from ESET. Apparently the uninstall you did deleted that file (that makes sense), but forgot to tell Windows that it wouldn't need to (and couldn't) load it anymore when booting in Safe Mode. That's surely bad. But it could be that it's caused by you starting the uninstall via ccleaner and not the regular way. Anyway, reinstalling Eset might do the trick, so you could boot again in Safe Mode. Then use the removal tool you downloaded.

It can be worse: https://forums.lenovo.com/t5/Lenovo-Yoga-Series-Notebooks/Missing-system-driver-after-Win-10-up-grade-Error-code/td-p/3423851 tells about installing Eset into a Windows 10 system makes that it won't boot anymore.

Collapse -
Cant reinstall

In reply to: Re: safe mode

I can't reinstall it. Says I already have the latest version. I saw the other post. There is no answer there yet.

Post was last edited on October 13, 2016 10:39 AM PDT

Collapse -
Re: can't reinstall

In reply to: Cant reinstall

Things to try:
1. System Restore back to before this unlucky happening.
2. Wait for a newer version of Eset and try again.
3. Refresh Windows from disc or USB-stick.

Collapse -
Idea

In reply to: Re: can't reinstall

What if I install same version of eset in a virtual machine with the same OS as my computer and then take the eelam.sys file from that VM and copy it in my computer? I already did the installation stuff and I found the eelam.sys file in the Windows/system32/drivers folder. Would this break my PC?

Collapse -
Perfect idea. Wouldn't do any harm.

In reply to: Idea

When you can boot again, go to the startup tab of msconfig (or from task manager if in Windows 10) or into services.msc to see if it's run at startup. If so, uncheck or set to disabled.

Collapse -
Answer
SOLVED!!!

In reply to: ESET uninstall failure/eelam.sys missing or corrupted

That's it. I solved it!!! I did VM thing and it worked. I installed eset on a VM that has the same OS as my machine and then found the eelam.sys file. I copied it in my machine and then was able to boot in safe mode. Then I used EsetUninstaller.exe (according to this post http://support.eset.com/kb2289/#win_vist_un) and now i am able to install eset again.

Collapse -
Very nice trick.

In reply to: SOLVED!!!

Thanks for telling.

Popular Forums

icon
Computer Newbies 10,686 discussions
icon
Computer Help 54,365 discussions
icon
Laptops 21,181 discussions
icon
Networking & Wireless 16,313 discussions
icon
Phones 17,137 discussions
icon
Security 31,287 discussions
icon
TVs & Home Theaters 22,101 discussions
icon
Windows 7 8,164 discussions
icon
Windows 10 2,657 discussions

DEALS, DEALS, DEALS!

Best Black Friday Deals

CNET editors are busy culling the list and highlighting what we think are the best deals out there this holiday season.