HolidayBuyer's Guide

Computer Help forum

General discussion

Error Saying TCP/IP not installed

by mazztroop / January 22, 2005 10:01 AM PST

I have DSL with a router connecting to two computers. When I select one of the network connections and choose properties, it shows a check mark in the Internet Protocl (TCP/IP) box. The General tab under properties shows the same thing as my other connections: "Obtain an IP address automatically." But while the other two conntections work fine, the one to my main computer does not. It stopped working immediately after running a spyware program (from Yahoo!). I have gone under windows components and added the TCP/IP protocol as a subcomponent under networking services. When I click on "Repair" after right-clicking on the connection, it continues to give the message that TCP/IP is not installed. Any ideas on how to fix this?

Discussion is locked
You are posting a reply to: Error Saying TCP/IP not installed
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Error Saying TCP/IP not installed
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
Mazztroup, Have You Tried?
by Grif Thomas Forum moderator / January 22, 2005 10:19 AM PST

First, it would sure help if we knew the operating system of the computer in question.

Next, try running the free program below and see if it reinstalls the connection software:

Repairs Winsock 2 settings caused by buggy software or improperly removed internet software:
http://www.cexx.org/lspfix.htm

Hope this helps.

Grif

Collapse -
Have not tried that yet
by mazztroop / January 22, 2005 10:33 AM PST

Sorry about leaving off the OS. I'm on Windows XP Home.

I just ran Net Diagnostics in the System Tools and it appears the specific item that is failing is the DHCPServer. Will this free program fix that?

Collapse -
Mazz, No Guarantees, But It's A Good Start...
by Grif Thomas Forum moderator / January 22, 2005 11:40 AM PST

That "DHCP Server" error basically means that your computer couldn't receive an IP address from the DSL server.

Just some options here....If the LSPFix doesn't work, do you know your IP address and have you tried changing your settings so it tries for that IP address only ??...(Open the Control Panel, open "Network Connections", RIGHT click on the "LAN Connections" icon, choose "Properties". Highlight the TCP/IP Protocol line, then click on the "Properties" button. When that loads, you would CHECK the "Use the following IP Address" and then type in the IP Address, Subnet mask, Default Gateway, DNS Server, etc.) BUT you would need to know all that information first.

Hope this helps.

Grif

Collapse -
Trying it again
by mazztroop / January 22, 2005 11:58 AM PST

I did try that and had no luck. I just tried again and still no luck. I have turned the firewall on and off but no change. When I enter the information in, it does not show up under properties, which concerns me. The free program did not have an affect either. But thank you for all your help, Grif. Any other ideas pop up, please let me know.

Mazz

Collapse -
Want to add
by mazztroop / January 22, 2005 12:01 PM PST
In reply to: Trying it again

This has happened before in the past and I found something that did work for those folks out there that have this problem. I used system restore. Now, this of course would only work if the configuration worked sometime in the past. Unfortunately, I lost that restore point with my last update.

Collapse -
Mazz, Have You Tried Reinstalling TCP/IP
by Grif Thomas Forum moderator / January 22, 2005 1:12 PM PST
In reply to: Want to add
Popular Forums
icon
Computer Newbies 10,686 discussions
icon
Computer Help 54,365 discussions
icon
Laptops 21,181 discussions
icon
Networking & Wireless 16,313 discussions
icon
Phones 17,137 discussions
icon
Security 31,287 discussions
icon
TVs & Home Theaters 22,101 discussions
icon
Windows 7 8,164 discussions
icon
Windows 10 2,657 discussions

HOLIDAY GIFT GUIDE 2017

Cameras that make great holiday gifts

Let them start the new year with a step up in photo and video quality from a phone.