General discussion

Error performing inpage operation

Bob, after you suggested IEFIX for a proplem I had ( I tried it and when I restarted, my computer went out of wack. It was really slow and it would restart all by itself. I don't know if it was IEFIX because I have been downloading some software lately. I thought it might be a virus, but I found that scanning my second partition was impossible. So I opened up My Computer and tried to open the partition and got an error:

D:\ is not accessible

Error performing inpage operation.

I hope there is a fix because there is at least 30 gigs of stuff I would hate to lose. Any help would be much appreciated.

I have Win 2k SP4.

(I am now pretty sure it isn't the hd)

Discussion is locked

Reply to: Error performing inpage operation
PLEASE NOTE: Do not post advertisements, offensive materials, profanity, or personal attacks. Please remember to be considerate of other members. If you are new to the CNET Forums, please read our CNET Forums FAQ. All submitted content is subject to our Terms of Use.
Reporting: Error performing inpage operation
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
- Collapse -
If this was me...

I'd reinstall the motherboard drivers. And maybe reapply the latest SP.

I've never lost a system due to IEFIX without good reason. It's just SFC and a few other items that a good system will not tank on.


- Collapse -
now i'm stuck

Thanks for the suggestion.

I couldn't really install anything, the SP or the driver, because the slowness problem was still there. I tried re-installing windows, but when the install got to the part where it looked like windows (with the grey windows, etc.) it started going slow again and took 6 hours to get through one step. So I tried a fresh install. Then it installed at full speed. But when it was done and I logged in, I still couldn't access the partition. (I hadn't even installed any drivers yet)

Are there any patitioning tools I should try? I have the Ultimate Boot CD, but I never know what tools to use for what. Thanks again.

- Collapse -
When you write tools for partitioning..

I can't know if you meant to create such or to repair such. But I will share I learned to only use the Windows 2000 CD to create partitions on a new install.


- Collapse -

I'm trying to fix the partition so I can access the files on it. (I didn't format or anything) There is about 30 gigs worth so I really need to fix this.

P.S. I'm still getting "Error performing inpage operation", even after the fresh install. I don't get this because the partition can be read with Knoppix but not a fresh install.

- Collapse -
This may be a not made by Windows 2000 partition or...

The drive was moved from another machine. Such an error is not uncommon under these conditions.

Since it is readable under KNOPPIX, I often install another drive, copy the files out, boot up 2000, use the disk management tool to remove the defective partition, create it again, format and then copy in the files.


- Collapse -
You're right, it wasn't

Made by Windows, that is.

I think I'll take your advice, but what do you suggest I use to move the files? I cant use knoppix because its NTFS.

- Collapse -
I use KNOPPIX because it can read NTFS with ease.

The target hard disk is often FAT32.


- Collapse -

Well duh! Thanks Bob, I wasn't thinking.

- Collapse -
It ain't easy.

You learn these tricks over time. And refine them the more you encounter systems that need fixing.

As you have been kicking this issue about, you have picked up a few new tools and tricks so the next time will get easier.


- Collapse -
cant find hd big enough

Thanks a lot for your help so far.

I don't know if I will be able to find a hd big enough. If I can't find one, is there ANYTHING else I can try?

- Collapse -
FAT32 means abotu 127GB volumes.
- Collapse -
back to ntfs problem

The partition is about 35GB with only 3GB free.

There is a HD on my network with enough space, but its NTFS. Is there a tool or something in Knoppix that will let me write to NTFS?

- Collapse -
Light reading.
- Collapse -
Yes, there is.

Across a network, KNOPPIX doesn't care what file system type is on the other side.


- Collapse -
thank you so much

Thank you, thank you, thank you!

I did just like you said and it worked like a charm. Although, for some odd reason I could only transfer files at 1.5MB a second, so it took 5 hours to transfer all the files. All I have to do now is move my files back to my HD.

I REALLY appreciate all the advice, Bob. I will certainly be coming back here whenever I need help next (a long, long time from now, I hope). Thanks again.

- Collapse -
Hey... I stick with it if you will.

I always feel better when the data is saved.



- Collapse -
external HD 100GB,USB2.0,problem copy files with KNOPPIX

I read your advises to ortzinator for problem with Error performing inpage operation, which led me to KNOPPIX.
First I have to say that now I will sleep better because I saw, thanks to KNOPPIX, that all 78 GBs of my data are still on my drive Happy
Still, I have some problem. It's little bit hard to work with KNOPPIX, because I'm just average user of Windows, so I'm not 100% sure how to solve my problem.
Not accessible drive is external hard drive (E: ) connected through USB2.0.
After booting KNOPPIX I saw all my files there, just the opening of folders takes ages, but it's no big deal. Problem is that when I tried to copy some files from E: to my C: it didn't allow me, saying ''couldn't create file xy in directory ..''
C: drive is where winXP are installed. Maybe this is the problem???
I could copy file on desktop of KNOPPIX, but I have no idea, where is that desktop and if I will be able to access those files after booting back winXP.
Do you have any idea how to copy files on my C: drive?
Thanks for whatever suggestion.

- Collapse -
This doesn't appear to belong in this discussion.

While it's likely that Knoppix is not performing at USB 2.0 speeds, it is performing so I'd count that as good enough to get your files back.

Your post doesn't appear to belong in this discussion but deserved it's own post since we are far off topic. You could also post in the Linux Forum in hopes that someone will comment about getting USB 2.0 speed.


- Collapse -
What was done exactly?

What exactly was done in order to solve this problem? I understand you used Knoppix... but in what fashion? Did you hook up the bad HD to a system that had Knoppix on it?

- Collapse -
It was revealed at...
- Collapse -
Here's what I did...

1. Booted the system into Knoppix.
2. Copied all the files on the bad partition via LAN to a folder on a hard drive on another system. There was nothing wrong with the files. There was something wrong with the partition that prevented Windows from being able to use the partition. Linux, in all its wonder, had no problems with it.

3. Deleted the bad partition.
4. Created a new partition.
5. Formatted the new partition.
6. Moved the files back with Windows.
7. Beamed with joy at my accomplishment.

I could've moved the hard drive to the other computer and then transferred the files with Knoppix, but the computer couldn't be sacrificed for that long and it would've been too much trouble.

Lesson learned: Partitioning a hard drive with a 5-year-old copy of Partition Magic is baaaad.

I hope I didn't miss anything. That was quite a while ago.

- Collapse -
Will this work with an external HD

Will this work with an external HD connected to the computer by a USB 2.0 cable?
I have a Hitachi 60GB hard drive that I removed from a damaged Notebook, put into a "hotdrive" hard case and connected to a USB port on my desktop computer. A Sony VGC-RB47G running Windows XP.
The HD worked perfectly for about a year until I loaded it up with approx 40GB of jpeg files. When I tried to move the drive to my desktop, it "died."
The computer "sees" the HD but I can't get it to do anything. I get that same message, "L:\ is not accessable. Error performing inpage operation."

- Collapse -
Yes.... it should

It should work as long as your external drive has no curuppted sectors and your USB Drive is supported by Knoppix as most are.. Good Luck and Happy Day

- Collapse -
Error performing inpage operation


I had this situacion once and I resolve it with KNOPPIX Linux CD. Through Linux you should be able to access your HDD. You have limited amount of time to do that but do your best.
When stops, you can try after some time again.
I hope this will help.


CNET Forums

Forum Info