Windows Legacy OS forum

General discussion

Error Msg: "Problem Ejecting USB Mass Storage Device"

by nikki605 / September 6, 2010 3:15 AM PDT

Yeah, I know, I've read all the Google results about "open files" and
"locking handles" too, but bear with me and keep reading.

This is on a WinXP Pro SP3 desktop, current with all critical updates. I have a laptop HDD that I've installed in an external case for USB 2.0 connection to my PC. It connects to the PC as drive letter D:\. It works fine backing up my data until it comes time to disconnect it. Then, when I try to Safely Remove Hardware, I get the error msg in the topic title, along with "The device 'Initio 0M9AT00 USB Device' cannot be stopped because a program is still accessing it."

So I fire up Unlocker 1.9.0 and it says "No Locking handle found." Then I fire up Process Explorer v12.04 and Search for D:\ - I get the result "0 matching items."

So WinXP thinks some program is still accessing it, but what? I need some other ideas or tools to figure out what is going on. Up to this point, I've just been shutting down all open application programs and pulling the USB cable.

Oh, and one more interesting tidbit - when I connect this same HDD to my Win7 x64 laptop and click on safely remove hardware, Win7 releases the device properly and I can safely remove it. ***?!?

Ideas... thoughts?

Thanks in advance for any help,

Discussion is locked
You are posting a reply to: Error Msg: "Problem Ejecting USB Mass Storage Device"
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Error Msg: "Problem Ejecting USB Mass Storage Device"
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
We Solve It By Turning OFF The Computer, Then Disconnect
by Grif Thomas Forum moderator / September 6, 2010 4:37 AM PDT

As you've found, there generally is no problem, but I've found a few such issues with flash drives as well.. Any opening or closing of folders or programs from the USB device will prevent it from being "released".. The only solution is to turn off the computer, then remove the device.

On a few machines, an update to the chipset driver of the BIOS version fixed the USB issue but not always..

Hope this helps.


Collapse -
by nikki605 / September 6, 2010 8:28 AM PDT

This is a 6-year old desktop & has the latest BIOS. It hasn't been updated in years from the manufacturer.

Guess I'll just keep doing what I've been doing Sad

Thanks for the reply,

Collapse -
Problem Solved
by nikki605 / October 15, 2010 2:41 AM PDT

Turns out it was the $9.95 Sabrent piece-of-junk enclosure that I bought at CompUSA. It started causing me other read/write & unexpected disconnect problems. Bought a better quality Vantec enclosure, installed the same HDD in it and VOILA, I can now 'safely remove hardware' from either PC and the other problems are gone as well.

I tried to save a few bucks and got burned. Argh! When will I learn?

Popular Forums
Computer Newbies 10,686 discussions
Computer Help 54,365 discussions
Laptops 21,181 discussions
Networking & Wireless 16,313 discussions
Phones 17,137 discussions
Security 31,287 discussions
TVs & Home Theaters 22,101 discussions
Windows 7 8,164 discussions
Windows 10 2,657 discussions


Help, my PC with Windows 10 won't shut down properly

Since upgrading to Windows 10 my computer won't shut down properly. I use the menu button shutdown and the screen goes blank, but the system does not fully shut down. The only way to get it to shut down is to hold the physical power button down till it shuts down. Any suggestions?