Mac OS forum


error code -50 with copying large avi files from mybooklive

by anis2002 / February 20, 2014 12:20 PM PST

I recently purchased macbook pro with retina display. I manage to transfer all my data from Windows laptop to macbook pro with no issues. I also have mybooklive network device from there whatever i want to copy, i copied it with no problem. the files includes doc, excel, txt, iso etc with all kind of size from 1kb to 4GB and it's copied with no problems.

Now when i try to copy an avi movie file of 700MB form mybooklive to macbook pro, it's copied with no problem. But when i try to copy an avi movie file over 2GB, i immediately got following error

The operation can't be completed because an unexpected error occurred (error code -50).

This error is appearing when i am copying .avi files. Other larger files are copying without any issues.

I also try to copy same file on my windows laptop from mybooklive and it's copied with no issues. Issue is coming only in macbook pro.

Mybooklive is formatted on NTFS format but i am able to copy/paste everything. I am also using it for my timemachine backup of around 150GB and it was done with no issues. Only problem is when i am copying larger .avi files.

Any help or suggestion.

Discussion is locked
You are posting a reply to: error code -50 with copying large avi files from mybooklive
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: error code -50 with copying large avi files from mybooklive
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
hi there
by anis2002 / February 20, 2014 6:48 PM PST
In reply to: Before we start

Thank you very much for your answer. However i already tried all above methods. I am still facing problem in copying .avi movie file larger than 1.5GB from mybooklive to macbook pro partition. Otherwise i am able to copy each and every file regardless of size.Even i am able to copy .mkv movie files. Problem is only with .avi file.

Collapse -
Re: unable to copy large avi-file
by Kees_B Forum moderator / February 20, 2014 7:19 PM PST
In reply to: hi there

In your post I read you are able to copy an equally large .mkv file. Then it's time to cheat.
1. Rename that file from .ave to .mkv. Renaming doesn't change anything in the file, it's just a name. You could use .ido or .bin just as well.
2. Copy the renamed file.
3. Rename the copy back to what it was.

Should work if there's nothing wrong with that specific file.


Collapse -
by anis2002 / February 20, 2014 10:02 PM PST

I tried to rename it and then copy it. Same problem Sad

Collapse -
Re: copy
by Kees_B Forum moderator / February 20, 2014 10:24 PM PST
In reply to: hi

Next thing to try: copy it from your Windows laptop to a USB-stick (FAT32 is fine). Then copy from there to your Mac. Does that work?


Collapse -
windows laptop
by anis2002 / February 21, 2014 12:01 AM PST
In reply to: Re: copy

i copied from mybooklive to windows laptop. i then share that folder for macbook and copied it to macbook pro, it's copied with no problem.

problem only coming when i am copying from mybooklive to macbook directly avi files lasrger than 2gb. smaller one are copying with no problems.

Collapse -
Re: copy
by Kees_B Forum moderator / February 21, 2014 4:22 AM PST
In reply to: windows laptop

Personally, I would be happy to know this work-around and use it.

If you aren't, well, you need to do some research. First I'd try the disk formatted in FAT32, then another disk, then the Mac restored to factory conditions, then another Mac.

If it fails with also with another Mac and other external disks, it's clearly an Apple issue. But if it works then, you might have located the source of the error during your research.



Collapse -
got the answer
by anis2002 / February 21, 2014 1:26 PM PST
In reply to: Re: copy

I manage to get the answer from another forum as follows:

"I cannot give you a specific solution since I am experiencing the same issue as you are. But it has something to do with SMB2 and the server you are connecting to. For example, here at work, I connect to multiple server types. Some connect fine, some do not.

One of our servers I get the -50 error when I try to transfer files like you do. A temporary fix is to connect as cifs://servername and I can connect now. It is not ideal, but will work for now.

So try:

Let me know if that works for you. Because it is working for me until we can get everything working properly."

And it's working fine. And this is MAC OS internal issue which hopefully apple will fix someday

Collapse -
Guess I missed the bit about this being
by mrmacfixit Forum moderator / February 21, 2014 10:17 PM PST
In reply to: got the answer

a Network device

Thanks for the followup


Collapse -
Clarification Request
If your Mybooklive is formatted as NTFS,
by mrmacfixit Forum moderator / February 20, 2014 8:52 PM PST

then you are not using it as a Time Machine backup destination.
Time Machine requires Mac OS (Extended Journaled) as the format for any drive it backs up to.

While OS X can READ from a disk that is formatted as NTFS it cannot WRITE to one without additional third party software.


Collapse -
by anis2002 / February 20, 2014 9:49 PM PST

i am using it as Time Machine Backup and it working fine. only problem is copy of avi file Sad
I also install NTFS for MAC OS X also.

All Answers

Collapse -
Time to use Apple's own file system.
by R. Proffitt Forum moderator / February 21, 2014 12:21 AM PST
Collapse -
Easy to solve mac error -50
by AlisaAlly / March 18, 2014 9:38 PM PDT

When there is wrong permission given for WebDAV or iDisk server then you may have to face problem in synching Mac data. Correct the permission of iDisk which can resolve the error. For this you can follow these steps:

<div>1. Go to Applications and then Utilities and Open Disk Utility
2. List of devices appears. Choose the start up disk from the list
3. And click to Repair permission.Performing the above step can solve your error easily.

If it cannot solve your problem then you should use third party repair tool to easily repair you problem and fix all mac errors or also speed up Mac.

Popular Forums
Computer Newbies 10,686 discussions
Computer Help 54,365 discussions
Laptops 21,181 discussions
Networking & Wireless 16,313 discussions
Phones 17,137 discussions
Security 31,287 discussions
TVs & Home Theaters 22,101 discussions
Windows 7 8,164 discussions
Windows 10 2,657 discussions


Help, my PC with Windows 10 won't shut down properly

Since upgrading to Windows 10 my computer won't shut down properly. I use the menu button shutdown and the screen goes blank, but the system does not fully shut down. The only way to get it to shut down is to hold the physical power button down till it shuts down. Any suggestions?