Spyware, Viruses, & Security forum

General discussion

Error code: -1 when trying to download

by Jesseballou / December 19, 2010 5:38 AM PST

I've been having problems with my laptop (64-bit windows 7) so I decided to try using free Ad-Aware (I removed my old virus program (Avira) because i couldn't update it) and disabled windows defender. The download was going great until i got an error "Connection error-check settings Error code: -1".
Is this a virus? Could this also have been the problem that was causing Avira to not be able to update? Any help will be appreciated.

Discussion is locked
You are posting a reply to: Error code: -1 when trying to download
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Error code: -1 when trying to download
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
Where does this error appear?
by MarkFlax Forum moderator / December 19, 2010 9:58 PM PST

I ask because it's not a normal Browser Error message.

What are you trying to download? Perhaps we can try.

How did you think AdAware would help you with downloading?

I'm not sure I would have uninstalled Avira and disabled Windows Defender. That leaves your system vulnerable. I would have fixed the Avira problems first.

Mark

Collapse -
Error code: -1 when trying to download
by Jesseballou / December 21, 2010 3:09 AM PST

This error appeared when I was trying to update AdAware after I initially downloaded it. I wanted to update it before i did my first AdAware scan. It popped up when I hit the Update AdAware button.

I hoped AdAware might find a virus or Malware that was preventing me from updating my old virus program (Avira). Actually, AdAware did find a virus and removed it, but i still can't update AdAware.

I tried to fix the Avira problem by looking at the report, and it appeared to have been telling me it couldn't find the WinNet program. When I researched WinNet, I was overwhelmed and decided maybe using another antivirus program might give me an explanation that I could work myself.

If this is something too big for a normal computer user, I'll take the computer into a professional.

p.s. the biggest headache is that I can't open World of Warcraft. I also keeps telling me that "Launcher cannot obtain patching information. Please check your internet connection".
Thank you for your interest in this problem!

Collapse -
In case this is malware related
by MarkFlax Forum moderator / December 21, 2010 3:27 AM PST

The first thing to do is check if there is any other malware on your system. AdAware isn't really an anti-virus or anti-malware scanner, so I would try both Malwarebytes' Anti-malware and SUPERAntiSpyware.

Follow the instructions below;

1] On this computer, download and install both Malwarebytes' Anti-malware and SUPERAntiSpyware. One at a time starting with MBAM, run each, update their definitions, then run a full scan.

2] If this virus doesn't allow you to use both MBAM and SAS in Normal Mode, try them both in Safe Mode. If you are unable to update either, run just MBAM in safe mode because it's installer file should have installed sufficient definitions to perform an initial scan and remove this.

3] If this virus doesn't allow you to download MBAM and SAS, use another computer, (relatives, friends, etc), to download both the MBAM and SAS installer files, then copy them to some external media like a CD or memory stick. At the same time, download MBAM's definitions from http://data.mbamupdates.com/tools/mbam-rules.exe and copy them to the media. Then use that to copy to your computer.

4] In some instances malware will try and prevent known anti-malware scanners from installing. In those cases, before copying MBAM to media, rename the installer file to some other name, eg "GoGetum.exe". Copy the file to the infected machine and run it to install MBAM. You may have to rename the MBAM executable application file to some other name before running it. Then use the updater file to update MBAM then run the scanner.

5] You 'may' have to run the MBAM scanner from Safe Mode.

6] After scanning with MBAM, then run SAS.

See if that helps, and please, go get a recognised anti-virus scanner installed, and make sure you have a firewall which is turned on.

Mark

Collapse -
Just a prior discussion.
by R. Proffitt Forum moderator / December 21, 2010 3:26 AM PST
Collapse -
AAW and WOW Issues
by Carol~ Moderator / December 21, 2010 4:52 AM PST

Jesse..

I don't know if your issue with Avira, is in any way related to your other problems. I only know, as far as the AAW connection error is concerned, it's quite common. So much so, it's been made "a sticky" at the Lavasoft forum.

As Mark suggested, I would first scan with MBAM and SAS.

"Cannot Update: Connection Error, Three Workarounds"

This topic is for users who experience a connection error error when trying to update Ad-Aware. For those users with Failed to Connect to Service errors, then please read this topic.

Workaround 1:

* Go to Control Panel > Administrative Tools > Services
* Locate Lavasoft Ad-Aware Service.
* Stop the Service (if started) and then right click > properties.
* Under Logon, check Allow service to interact with desktop, click OK and restart the service.

Workaround 2:

Applies only to Windows Vista.

* Open C:/Program Files/Lavasoft/Ad-Aware
* Right click on AAWService.exe
* Properties > Compatibility > Run this program in compatibility mode for: Windows XP (Service Pack 2) - some users who have reported this not working, have said that setting compatibility to Windows 98 SP2 works.
* OK
* Right click on Ad-AwareAdmin.exe and follow the same instructions.

Workaround 3:

It has been reported that for some users who had the service Terminal Services disabled could not update, but once enabled they could update. The workaround is then to enable Terminal Services.

* Go to Control Panel > Administrative Tools > Services
* Locate Terminal Services
* Click Properties > and choose start up type as automatic
* Restart your computer


_________

Your World of Warcraft "headache":

That too seems to be a common problem. Throughout the first thread, users have offered what "worked for them". Read all the posts, to include the last.

World of Warcraft > Launcher cannot obtain patching information

Launcher cannot obtain patching information.

Best of luck..
Carol

Popular Forums
icon
Computer Newbies 10,686 discussions
icon
Computer Help 54,365 discussions
icon
Laptops 21,181 discussions
icon
Networking & Wireless 16,313 discussions
icon
Phones 17,137 discussions
icon
Security 31,287 discussions
icon
TVs & Home Theaters 22,101 discussions
icon
Windows 7 8,164 discussions
icon
Windows 10 2,657 discussions

Does BMW or Volvo do it best?

Pint-size luxury and funky style

Shopping for a new car this weekend? See how the BMW X2 stacks up against the Volvo XC40 in our side-by-side comparison.