Windows Legacy OS forum

General discussion

Error Applying Attributes

by GeneBobTX / October 2, 2004 12:29 AM PDT

I can't seem to manipulate a file folder which I created with an application (PhotoImpact). I can see the file name and sizes, but any attempt to access them meets with a "File not found" error.

I started at My Computer and navigated to the directory, and then tried to clear the (grey) Read-Only attribute (files copied from digital camera) but it inevitably leads to:

"An error occurred applying attributes to the file:

C:\Documents and Setting...\Foo.jpg

Access is denied.

I suspect the file ownership is a problem, but it looks the same as all other files. Where can I diagnose and fix this problem?

Discussion is locked
You are posting a reply to: Error Applying Attributes
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Error Applying Attributes
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
Re: Error Applying Attributes
by Coryphaeus / October 2, 2004 12:35 AM PDT

If the file is in use, you'll get this message. Have you tried closing down PhotoImpact first?

Collapse -
Re: Error Applying Attributes
by GeneBobTX / October 2, 2004 3:05 AM PDT

Yes, I tried that. No luck. (problem now solved .. see the thread for info on CACLS.EXE)

Collapse -
Re: Error Applying Attributes
by R. Proffitt Forum moderator / October 2, 2004 12:36 AM PDT

Check the ownership of the file as well.

"Although the Properties page is the basic user interface for viewing and modifying ACLs and ACEs, it is not usable for configuring security for all types of objects on a network or Windows XP Professional?based computer. In some cases you can use the tool Cacls.exe to perform security configuration tasks."
- http://www.microsoft.com/resources/documentation/Windows/XP/all/reskit/en-us/Default.asp?url=/resources/documentation/Windows/XP/all/reskit/en-us/prdd_sec_jynl.asp

For me, CACLS is the next stop.

Bob

Collapse -
Re: Error Applying Attributes
by GeneBobTX / October 2, 2004 3:03 AM PDT

interesting, Bob, pointing me to CACLS.EXE allowed me to fix the problem (THANKS!).

The problematic files show NO attributes when I inspected them with CACLS.EXE .. I suspect I created the directory from inside the application (which is apparently not XP-aware).

I edited the LONG directory name, but here's the idea of what I found (the first directory was working okay, so I compared it with the 2nd directory):

C:\...\ONE\> cacls P9111114.JPG
C:\...\ONE\P9111114.JPG HP-A620N\Owner:F
NT AUTHORITY\SYSTEM:F

cd ..\TWO

C:\...\TWO\> cacls rfid-50.jpg
C:\...\TWO\rfid-50.jpg (note: NO permissions!)

C:\...\TWO\> cacls rfid-50.jpg /G Owner:F
Are you sure (Y/N)?y

and then, to confirm all's well:

C:\...\TWO\> cacls rfid-50.jpg
C:\...\TWO\rfid-50.jpg HP-A620N\Owner:F

I also am now able to access them via the application, when I couldn't do that before.

Epilogue: these files landed in the \Owner heirarchy somehow, versus \My Pictures .. I will now move them around and adjust the ACLs accordingly. Hmmm.

Collapse -
No more secrets...
by R. Proffitt Forum moderator / October 2, 2004 3:31 AM PDT

I think you've cracked the code. Nothing will get by you now!

Bob

Popular Forums
icon
Computer Newbies 10,686 discussions
icon
Computer Help 54,365 discussions
icon
Laptops 21,181 discussions
icon
Networking & Wireless 16,313 discussions
icon
Phones 17,137 discussions
icon
Security 31,287 discussions
icon
TVs & Home Theaters 22,101 discussions
icon
Windows 7 8,164 discussions
icon
Windows 10 2,657 discussions

CNET FORUMS TOP DISCUSSION

Help, my PC with Windows 10 won't shut down properly

Since upgrading to Windows 10 my computer won't shut down properly. I use the menu button shutdown and the screen goes blank, but the system does not fully shut down. The only way to get it to shut down is to hold the physical power button down till it shuts down. Any suggestions?