Thank you for being a valued part of the CNET community. As of December 1, 2020, the forums are in read-only format. In early 2021, CNET Forums will no longer be available. We are grateful for the participation and advice you have provided to one another over the years.


CNET Support

General discussion

"ERROR 1606 could not access network location..."

May 20, 2005 4:20AM PDT

?Error 1606 could not access network location

This issue has been posted a number of times in this forum, unfortunately, though looking through many of the posts; I have not been able to resolve the problem.
I have Windows XP Pro SP2 with latest updates and IE v6.0.2900.2180 xpsp2
Trying to uninstall a program to my surprise received following message: ?Error 1606 could not access network location %USERPROFILE%\Recent?. I Google searched and found various options, mainly:

-Locate and then click the following registry key:
HKEY_Local_Machine\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders
-In the right pane of Registry Editor, double-click Common Administrative Tools.
-In the Value data box , type the following line, and then click OK:
%ALLUSERSPROFILE%\Start Menu\Programs\Administrative Tools

However, the ?Common Administrative Tools? under User Shell Folders in my registry is non-existent, it is not there. I have also gone to the following key: HKEY_Local_Machine\Software\Microsoft\Windows\CurrentVersion\Explorer\Shell Folders and changed the value data from C:\Documents and Settings\All Users\Start Menu\Programs\Administrative Tools to %ALLUSERSPROFILE%\Start Menu\Programs\Administrative Tools, rebooted, but still got the same issue. I have tried the option of installing ?Windows Installer Clean-Up utility? to remove any vestiges of earlier installer progs that may still be screwing around, but to no avail. In fact, was unable to install this utility because received same dam message. It?s funny because I have since installed two other apps and everything went ok. Could the missing entry ?Common Administrative Tools? in the User Shell Folder be the cause of this issue,

Discussion is locked

- Collapse -
Stoneblack, Maybe....
May 20, 2005 5:16AM PDT

These are the fixes for that error that I am familiar with...The first one usually does it.

Click on ?Start-Run, type ?regedit? (without the quotes) Navigate to this registry path:
HKEY_CURRENT_USER --> Software --> Microsoft --> Windows --> Current Version --> Explorer --> User Shell Folders
Clear the key: Recent (right mouse click on the key/folder, choose ?Delete?) Close the Registry Editor and restart the computer.

Or ?. ?Error 1606. Could Not Access Network Location <Common Administrative Tools>.All Users\'' Error Message When You Install a Program?;en-us;Q315352

Or?.?Error Message When You Install Plus! for Windows XP: ''Error 1606. Could Not Access Network Location'';en-us;Q307683

Hope this helps.


- Collapse -
Error 1606...Your Fix Worked!!!
May 20, 2005 10:48AM PDT


Many thanks for your fix. It worked!! Bloody hell... I don't know what to just did away with a whole lot of stress and made my day. I can tell you I've been mucking around in various forums that have never come even close to your work around solution. I've been at this for days, just about given up...

Again, many thanks for your solution and your help.

Cheers mate.

- Collapse -
(NT) (NT) Good Job & Glad It Helped !
May 21, 2005 4:16AM PDT
- Collapse -
Thank you!
May 24, 2005 10:39AM PDT

Grif Thomas,

I have also been looking for a solution to the 1606 problem that had been preventing me from downloading FraudEliminator. You solved my problem - many thanks!

- Collapse -
(NT) (NT) Amblawn, Glad It Helped!
May 25, 2005 12:09AM PDT
- Collapse -
Similar problem in XP - any ideas?
Jun 21, 2005 12:26AM PDT

Hi, I got an iPod shuffle for Father's day and
am trying to load the s/w from the disc but keep
getting this Error 1606: Could not access network location: %USERPROFILE%\Favorites. I understand this is
a problem with the registry relating to the install shield, and found lots
of references to fixing this problem when it refers
to Recent or Administrative Tools directories, but
none seem address this particular problem? I checked the registry
entries under both
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders\ and HKEY_CURRENT_USER\etc. and they appear
to be correct from what I can tell, e.g. both have similar path entries, where CURRENT_USER has %USERPROFILE% prefix while LOCAL_MACHINE has the %ALLUSERSPROFILE% prefix.
I found and downloaded a registry audit/repair tool on the Microsoft site, but in true catch-22 fashion, can't install it on my PC because of this install shield related Error 1606!
Please help!
Thanks in advance,
Bill Schickman

- Collapse -
Bill, Which XP Service Pack? And Have You Tried??
Jun 21, 2005 1:24AM PDT

...removing the "Recent" key per my first instructions. It won't hurt anything and usually fixes the problem similar to yours..

In addition, there is a brand new Windows Installer 3.1 V2 and it's possible that it will help the issue. Here's a direct link to that file:

Windows Installer 3.1 Redistributable (v2)

If that doesn't cure the issue, then it sounds like your specific issue is similar to the second link I posted earlier..(See Below)Although your issue is with the "Favorites" folder, it may have become redirected somehow. Try the the workaround but with the Favorites folder in mind instead of "My Documents".

?Error Message When You Install Plus! for Windows XP: ''Error 1606. Could Not Access Network Location'';en-us;Q307683

Hope this helps.


- Collapse -
Tried deleting the Recent folder
Jun 21, 2005 3:49AM PDT

Hi Grif, yes, I did try deleting the Recent folder
and rebooting, but it didn't help. I'm not sure which
service pack I'm running, but I do have automatic
update "on" if that helps. It's XP Home Edition.
I will try the new install link you mentioned
and let you know how I make out.

- Collapse -
Bill, To Determine Which Service Pack..
Jun 21, 2005 5:03AM PDT

RIGHT click on "My Computer", choose "Properties". When that loads, on the "General" tab, under "System", you'll see the Windows version and service pack version listed.

Hope this helps.


- Collapse -
Got the problem solved, brute force method!
Jun 21, 2005 11:49PM PDT

Just a quick update, I finally got the problem solved!
First, I tried all deleting the Recent entry again,
rebooted, no help. Then I downloaded the new Windows
installer and loaded it, same problem. I looked at the
other links to the 1606 problem that relate to
other registry entries and could't apply the fixes
to my problem, as there was no problem with the
Favorites entry in my registry! Finally, I decided to
delete the Favorites entries for both HKEY_LOCAL_MACHINE
and HKEY_CURRENT_USER, and re-create them manually (i.e.
type in a new entry) exactly as they were previously
listed. Rebooted, and it finally worked! So there
must have been something wrong with one of the entries
that was not visible. Anyway, I'm happy
that this worked, but still wondering how the hell
the registry would all of a sudden have a problem like

Thanks for all your suggestions,

- Collapse -
That smells of what WINSOCKXPFIX does.
Jun 21, 2005 11:53PM PDT
- Collapse -
(NT) (NT) Bill, Thanks For Posting Back With The Fix
Jun 21, 2005 11:59PM PDT
- Collapse -
error 1606
Feb 3, 2006 5:12PM PST

thanks for the forced entry way I can find favourites only in HKEY_CURRENT_USER but not in HKEY_LOCAL_MACHINE can you pinpoint where in the registry i fine d this i ran find and it came up with nothing

- Collapse -
Fred, If It's Only In One Registry Location, That's Fine
Feb 4, 2006 4:02AM PST

It's not always in both..Simply fix the ones you find.

Hope this helps.


- Collapse -
Need help with Error 1606
Mar 17, 2009 2:05AM PDT

I've been reading all over the internet, and tried the fixes re the user files, I've check out both and fixed what I could find. Still I can't install a wordperfect program or remove any programs. This is the error I get.

error 1606 could not access network location

- Collapse -
And You've Tried EVERY Suggestion In This Thread
Mar 17, 2009 3:26AM PDT
- Collapse -
Computer info (sorry) :-/
Mar 17, 2009 4:01AM PDT

Sorry about the no info. YikesHappy

Dell DM051
Pentium 4
Windows XP home ed Service pac 3

I was wondering, could the problem have anything to do with my win auto updates not working? For some reason, that keeps getting disabled.

I'll check out the other links you sent.

thank you

- Collapse -
It's Possible That Both Are Related
Mar 17, 2009 4:28AM PDT

Malware can cause both issues. Just in case it's a malware problem, please follow the steps below:

On a friend or family member's computer, download the Malwarebytes installer and update files from the links below, copy them to a CD or flash drive, then transfer the files to the problem machine and use them. If you can't start the computer into "normal" windows, try installing, updating, and running the scans AFTER the computer is started into Safe Mode.. I use the sites below to download the installer file and the manual updater:

Once downloaded and before transferring them to the problem machine, rename the program installer "mbam-setup.exe" file to something else like "Gogetum.exe", then copy the installer file and the update file to a CD or flash drive.. Transfer the file to the problem machine, then install the "Gogetum.exe" file, then run the update to get the program current.. After that, run a full system scan and delete anything it finds.

Malwarebytes Installer Download Link (Clicking on the links below will immediately start the download dialogue window.)

Malwarebytes Manual Updater link

Next, download the SuperAntispyware program and the manual updater from the links below. After running the Malwarebytes tool above, if you still can't download and install it directly from the problem machine, download it on a friend or family member's computer as well. After installing and updating SuperAntispyware, run another full system scan and delete everything it finds as well. As before, you may need to rename the installer file to get the program to install.:


SuperAntispyware Manual Updater

In a few situations, in order for the program to run, it was also necessary to rename the main "mbam.exe" file also after installing it.. It resides in the C:\Programs Files\Malwarebytes Antimalware folder.

If you find nothing using the scans above or the problem isn't fixed, in order to get Windows Updates running, please try the steps below:

(Borrowed From PudgyOne/Rick)

Re-register the Windows Update DLL with the commands below
Click Start, click Run, type cmd, and then click OK.
Type the following commands. Press ENTER after each command.
regsvr32 wuapi.dll
regsvr32 wuaueng.dll
regsvr32 wuaueng1.dll
regsvr32 wucltui.dll
regsvr32 wups.dll
regsvr32 wups2.dll
regsvr32 wuweb.dll

Attempt to run Windows Update

Hope this helps and let us know how it goes.


- Collapse -
Almost the same problem except...
Dec 25, 2009 1:25PM PST

Hi I have currently got exactly the same problem here, except I cannot run the Microsoft Windows Installation Cleanup Utiliy - any advice for this is much appreciated

(: Dan

- Collapse -
Then Follow the Steps In This Thread...
Dec 27, 2009 8:35AM PST

..You'll need to perform the registry edits mentioned and make sure to read all of the posts in this thread.. There are a number of different options depending on your specific 1606 error and the operating system you're using, none of which you gave us in your post.

Hope this helps.


- Collapse -
Oh thanks I figued it out!
Dec 27, 2009 9:03AM PST

Thanks, sorry about the unspecifics, but it didn't end up giving me anything to work with in the way of specifics anyway but it's all figured out now and the problem itunes installed (Y)

Thanks alot for your help though!

- Collapse -
Thanks Grif
May 28, 2005 10:13AM PDT

Your first solution (simply deleting the "Recent" key in the appropriate registry path) solved the problem for me as well. I spent useless hours attempting to correct the Windows Installer problem by following Bill Gates' advice and that of others as well. I don't have a clue how you knew the solution but I'm a happy camper.

- Collapse -
Nov 22, 2008 9:39AM PST

Dear Grif
I have removed the Recent file but it still does not allow me to install Adobe 9

- Collapse -
Lots Of Other Suggestions In This Thread..
Nov 22, 2008 12:25PM PST

If you've only tried the one "recent" key deletion from the registry in one location, you've got other things to try.

You'll need to know how to edit the registry well.. Be sure to make a backup of the registry before making the deletions from the registry.. and try the other suggestions in the links below, which are from this thread..;posts#1499123

Hope this helps.


- Collapse -
error 1606 could not access network location\startup
Nov 23, 2008 6:50AM PST

Thanks Grif
I tied it but it did not help. but I did find help here. and it worked perfectly:
Post 12 of 22 | Next unread | Back to top
For future reference...
by SwissJay - 8/3/07 6:52 PM In reply to: Still getting 1606 errors attempting to install Acrobat. by erm909
This problem caused me quite a headache and few lost hours of work, but I finally managed to figure it out.

It seems to happen only if you've had multiple versions of Office installed on the machine. In my case, the machine had Office XP which was later upgraded to Office 2003. When you install an Adobe product, it tries to install macros in the Excel XLSTART and Word STARTUP folders and checks the registry for the correct path to put in front of that.

It opens
etc. and looks at the 'Path' key for that. But if it doesn't exist, instead of skipping that version of Office, it returns a blank string resulting in the installation being unable to find the \Startup folder and aborting.

To work around that, I created a new 'String Value' called 'Path' and put the same path in every one, no matter the version. In my case, this was 'E:\Program Files\Microsoft Office\OFFICE10\'. The folder STARTUP already existed in 'E:\Program Files\Microsoft Office\OFFICE10\' so after updating the registry, I ran the installation again and it griped about \XLSTART.

So I went back to
and added a 'String Value' called 'Path' just like I did for Word.

After this final registry update, the installation ran through without a hitch!

Hope it helps someone!
Post 12 of 22 | Next unread | Back to top

- Collapse -
(NT) Good Job & Thanks For Posting Back!
Nov 23, 2008 8:29AM PST
- Collapse -
error 1606
Nov 27, 2009 8:29AM PST

icould'nt download acrobat due to error 1606,toshiba and windows vista.i delete already the anti virus w/c is mcafee.

thanks and hope you will help me.


- Collapse -
Have You Tried ALL The Suggestions In This Thread...
Nov 29, 2009 9:27AM PST
- Collapse -
Many thanks for the solution for Error 1606!
Jul 4, 2005 8:29AM PDT

Dear Grif,

All of a sudden my HP PSC 1210 wouldn't do anything but copy. I spent hours looking through the Knowledge Bases for both Windows XP and HP, and 3 unsuccessful chat sessions with HP, using System Restore twice as a last resort. In a fit of frustration this morning, needing the printer for work tomorrow, I Googled the error and found your solution. I can't tell you how grateful I am. Thank you very much! You did HP's job for them- shame on them. Perhaps theses vendors owe the people who come up with solutions a consult fee! What do they get paid for, anyway? If I could find a link as a non-technofile, you'd think they'd point people in that direction. They had me deleting Registry files, uninstalling the USB ports and drivers, and one one occaision not very politely. Again, THANK YOU!!


- Collapse -
(NT) Thanks A Million
Aug 12, 2005 3:19AM PDT

I also have been searching to a solution for Error 1606 and have not found any fix that works.....until I rad your message. I finally got rid of Error 1606 and am now able to install my programs.

Thank you, thank you, thank you!