Windows 7 forum

General discussion

Error 0x000006cc while trying to share a printer

by swannn / November 9, 2010 4:17 AM PST

I'm running windows 7 ultimate 64bit on my PC, with a samsung printer connected directly to it via USB.
trying to share this printer results in 0x000006cc error.

I tried disabling the firewall but it didn't make a difference.
I made some changes to the homegroup, disabling and enabling printer sharing, but it still didn't work.

any ideas?


Discussion is locked
You are posting a reply to: Error 0x000006cc while trying to share a printer
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Error 0x000006cc while trying to share a printer
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
I already bumped into this link
by swannn / November 9, 2010 9:05 AM PST

I tried the firewall thing but it didn't work. I'll have to consider making the changes to the registry with the RPC ports. does this mean that I need to choose a specific port?

Collapse -
So you tried it?
by R. Proffitt Forum moderator / November 10, 2010 12:00 AM PST

I'm running into folk that won't try what worked for others. I think that when it comes to registry they freak out.

-> Here's my thought. If the product claims to be shareable and fails then pack it up and return it for a product that works out of the box without diving into the registry. The HP and Canon printers we have at the office do this without registry edits.

Collapse -
I will try it, i wasn't too happy to change the registry yet
by swannn / November 10, 2010 1:35 AM PST
In reply to: So you tried it?

This is a sumsung printer that was successfully shared on an XP machine and on this windows 7 machine when I first installed it, and worked for a while.
it still works locally, only the local windows cannot share it.
it must have been on of the windows updates that did it. (my thought).

Collapse -
by swannn / November 10, 2010 1:43 AM PST
In reply to: So you tried it?

the only thing i did (after shutting off the firewall, which originally didn't make a difference) was to restart the Printer Spooler service.

I shared the printer, started the firewall, and was able to connect from another computer and print.


(no registry changes :-))

Collapse -
Just wondering.
by R. Proffitt Forum moderator / November 10, 2010 1:46 AM PST
In reply to: Solved!

Wouldn't we have rebooted after sharing or before? Seems that would have done the trick too.

Collapse -
Fix for printer share 0x000006c error
by Dapper13 / January 11, 2011 1:14 AM PST

I found a fix for the 0x000006cc error - which worked for me.

I had this problem as a consequence of my deciding to change the name of the printer attached to my Windows 7 machine. Afterwards the printer which had worked satisfactorily as a shared printer for some time could no longer be set to share. I got the 0x000006cc error and a warning that the new settings could not be saved. This continued even when I changed the name back to its original.

I went to Control Panel/ Administrative Tools / Services.

I then found Printspooler and stopped this service... I then restarted the Printspooler.

I returned to Devices and Printers and when I then set my printer to sharing and applied the change, this was accepted without problem.

Hope this works for someone else................... Dapper13

Collapse -
windows 7 pritner sharing problems
by michelsmith / August 18, 2011 2:28 PM PDT


You need to now connect other systems to the Homegroup.

To do this, you need to access 'Control Panel' from the 'Start menu' and select the 'Choose Homegroup and sharing options.'

It will display a message that the Windows has detected another homegroup on your network.

At the time, you need to click the 'Join Now' button.

It will then ask for a password and you need to enter the password you got after you have created the Homegroup.

Just click the 'Finish' button and get the system connected.

Collapse -
Thank you
by RikJJ / September 27, 2011 2:16 AM PDT


Sometimes the simplest solutions are the best. I know you wrote this post a while back but it worked perfectly for me.

Thanks again


Popular Forums
Computer Help 51,912 discussions
Computer Newbies 10,498 discussions
Laptops 20,411 discussions
Security 30,882 discussions
TVs & Home Theaters 21,253 discussions
Windows 10 1,672 discussions
Phones 16,494 discussions
Windows 7 7,855 discussions
Networking & Wireless 15,504 discussions


Want to see the future of car technology?

Brian Cooley found it for you at CES 2017 in Las Vegas and the North American International Auto Show in Detroit.