General discussion

Erase disk with no root priv.

can anyone help? i have a 12" G4 powerbook running Mac OS X 3.3, i remember my login which isn't a root login, but have forgotten my admin password. i also do not have the original OS X disks to change it. i want to erase the hard disk and install OS X fresh so i have root access to make changes etc. but i have had no luck. it wont mount via firewire onto the desktop of my other mac, it wont boot from a CD... I'm stuck!

Discussion is locked

Follow
Reply to: Erase disk with no root priv.
PLEASE NOTE: Do not post advertisements, offensive materials, profanity, or personal attacks. Please remember to be considerate of other members. If you are new to the CNET Forums, please read our CNET Forums FAQ. All submitted content is subject to our Terms of Use.
Reporting: Erase disk with no root priv.
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Comments
- Collapse -
Passwords

Unless you have any X.3.x installation disks, and can boot from them, then you are generally SOL.
The major question here is not that you cannot change your password, but that you cannot boot from the CD. Will it boot from any CD? Will it read any CD's? How were you planning on installing OS X fresh without any installation disks?
Go beg, borrow or otherwise obtain, a set of Panther installation disks. If you are trying to boot from the RESTORE disks from another Mac, you are probably wasting your time. They are machine specific.

P

- Collapse -
OS X panther 10.3 disks

i do have panther 10.3 disks, but it will not boot from the disk, i turn the machine on with disk one inserted, hold down C or apple C and it always just takes me to the log in screen which i set up when i bought the computer - admin login, or one for the family with no access priv. it's the admin password i have forgotten and the install disks i have borrowed just don't seem to be working. is there no other way of wiping the HDD when i'm in the non admin login?

- Collapse -
Panther install disks

Make sure that you have an undamaged install disk.
Put the CD in the drive. When it appears on the desktop, open it up and go to the Install OS X icon.
Double click it. The machine should reboot from the CD and allow you to go to the File menu and reset the password.
If the machine does NOT boot from the CD, then the CD is damaged or your CD drive is not functioning correctly.
When booted from the Installation CD, the machine will NOT go to any password screen until you tell it to.
Reset password is in the File menu of the install window


P

- Collapse -
Admin password needed

The drive reads the disk and it shows on the desktop, but when i try to intstall OS X it asks for my admin password.

when i try and boot from the disk it sounds like it's reading the disk, but the OS X login screen always appears.

i can't understand why it will not boot from a disk because even if i did know my root password it is still not letting me boot from the disk. i know the disk works because i installed OS X on my home G4 tower from this disk.

is there no software available that will delete the HDD? after all i'm not trying to access password protected files, i'm just deleting them right??

- Collapse -
Wrong

Part of the strength of OS X is that its Core, and a bunch of other places, is protected against what you are trying to do to it. This is one of the many reasons that there are currently no Virus's for OS X. To delete the files you have to have access to them AND have the rights to read/write and delete.
You are going to have to boot from the CD to install OS X so I would not be too quick to blow away the HD. The OS X installer will not install to the Drive that it is mounted on.
I would continue my efforts to boot from the CD. Have you tried inserting the CD, mounting it on the Desktop, going to System preferences, choosing the CD as the startup disk and then restarting??

If not, try it. You are going to have to boot from the CD eventually. (See above)

P

- Collapse -
everything is greyed out

i can't boot the disk as a startup disk because the packlock is locked and i need an admin pass to make changes. i don't understand why i cannot boot from a disk. surely you can boot from any disk right?

is there software available to overwriye the admin password protection? if not i think i'm going to have to buy a new HDD

- Collapse -
software

I know of no software that will over ride the Administrators password. that does not mean that it does not exist though.
I will keep banging the "You gotta boot from the CD" drum though. Once you get your brand new, virgin, HD, how do you propose to get the OS onto it? To install OS X onto the new HD, you will HAVE to boot from the CD.
You can only boot from a CD that has the correct operating system for your machine. However, your machine should boot from the original Panther CD's. You said you had the Panther disks, the Three black ones?
Does the machine boot from ANY CD?

P

- Collapse -
disks

yes i have the three black panther disks, it will not boot from these, nor will it boot from any other CD that i've tried so far. could it be that i'd upgraded to OS X 3.5 before i lost my root password and the machine will not boot from these disk as they are only 3.3?

should i try getting a later version of OS panther to see if that works? the thing i can't understand is that my home desktop G4 runs on OS X 3.3 and i can boot from any disk on that machine. could i have turned my powerbook's "option to boot from a CD" off in anyway? or perrhaps the powerbook needs to be running in single user (root) mode to be able to boot from a disk?

- Collapse -
Boot

Panther only comes in one flavor on a CD. You have to update from there. Unless the CDROM drive is faulty, I don't think there is any reason why it would not boot from the install disks. This might be worth biting the bullet and speaking with Apple.

CNET Forums

Forum Info