Mac Applications forum

General discussion

Epson SC740 printer stopped printing

by alanwoollcombe / October 10, 2009 5:29 AM PDT

Hi.

I recently reinstalled my operating system (OS 10.4) from the original system disks in a vain attempt to stop a problem with Mail (it has started demanding my password repeatedly before it will send any mail). I then had to download and reinstall all the various upgrades since.

Since then it no longer recognizes my Epson SC740 printer. It won't let me install the driver from the original CD - it comes up with the error message "You cannot open the application 'Installer' because it is not supported on this system."

I then went to an Epson download site and downloaded the only driver they had for Macs, but double-clicking on the Installer icon produced the same error message.

I went to System Preferences/Print & Fax/Printing to see what there was. The printer showed up there.

I clicked on the Remove (-) button to remove it and then on the Add (+) button as recommended in one of the Apple Support documents. The Printer Browser window which opened again showed the printer so I clicked on it. The name and location boxes appeared filled in correctly, but the Print Using... box had several options, some greyed-out. The only active options were: Other..., Apple or ESP.

Of these, the Apple option lists only Apple printers, the Other... option opens the Finder, and the ESP option (what is ESP?) comes up with six Epson printers. They are:

Epson 24-pin series CUPS v1.1
Epson 9-pin series CUPS v1.1
Epson New Stylus Color series CUPS v1.1
Epson New Stylus Photo series CUPS v1.1
Epson Stylus Color series CUPS v1.1
Epson Stylus Photo series CUPS v1.1

Which is the right one, and what do I do next?

Thanks for any help - this is all guesswork on my part so far, so please correct any missteps I have made so far. Thanks again,

Alan

Discussion is locked
You are posting a reply to: Epson SC740 printer stopped printing
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Epson SC740 printer stopped printing
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
Epson 740
by mrmacfixit Forum moderator / October 11, 2009 12:37 AM PDT

My guess is that the original CD was for System 9 and will not work in OS X.

The printer itself is getting on in years but if it's still working, who cares.

The driver you should choose is the Epson New Stylus Color series, (740SC = 740 Stylus Color), and see how you get on.

P

Collapse -
Printer not working
by alanwoollcombe / October 11, 2009 4:49 AM PDT
In reply to: Epson 740

I think you're right about the CD (as the Installer won't install), but nonetheless this printer has worked flawlessly with this computer using OS X for the last three years and its predecessor before that.

Anyway thanks for the suggestion - I'll try it.

And if that doesn't do the trick, when the printer was working, it was pretty poor quality so maybe now is the time to invest in another one.

Alan

Collapse -
Epson SC740 printer stopped printing
by alanwoollcombe / October 11, 2009 4:54 AM PDT
In reply to: Printer not working

OK, just tried it but, although the system sees the printer, something repeatedly stops any printing jobs. The cables are plugged in, the lights are on, but nothing's happening at the printer end (none of the usual catalogue of noises).

Any ideas?

Collapse -
Pull the power cord out
by mrmacfixit Forum moderator / October 11, 2009 8:55 AM PDT

and wait for about 5 minutes.
Plug it back in again and see what happens


P

Popular Forums
icon
Computer Newbies 10,686 discussions
icon
Computer Help 54,365 discussions
icon
Laptops 21,181 discussions
icon
Networking & Wireless 16,313 discussions
icon
Phones 17,137 discussions
icon
Security 31,287 discussions
icon
TVs & Home Theaters 22,101 discussions
icon
Windows 7 8,164 discussions
icon
Windows 10 2,657 discussions

CNET FORUMS TOP DISCUSSION

Help, my PC with Windows 10 won't shut down properly

Since upgrading to Windows 10 my computer won't shut down properly. I use the menu button shutdown and the screen goes blank, but the system does not fully shut down. The only way to get it to shut down is to hold the physical power button down till it shuts down. Any suggestions?