Question

Epson R3000 problem since 10.8.2 & iPhoto 9.4 update

Hi

I'm a new Mac user, having purchased a current generation iMac in the past 4 weeks, with Lion installed which I then upgraded to the original Mountain Lion release using the free Apple upgrade offer.

I then purchased an Epson R3000 and successfully installed it and have been happily using it (wirelessly) to print some lovely images.

I haven't used the printer for the last 4 or 5 days, and yesterday I installed OSX 10.8.2 and the iPhoto 9.4 updates.

There are no problems viewing/editing my photos in the new release, but now, when I try and print a photo using either iPhoto or the Easy Print Epson utility, the job appears to be sent to the printer, but shortly thereafter returns an error message along the lines of "Stopped - Filtering error".

I don't even know what the error message means, let along how I might solve it, so I have no idea whether either of the software updates might be a problem, or whether that's probably just a timing coincidence.

The Mac still recognises the printer and the printer itself is indicating that the wifi signal strength is excellent. I've tried several different photos. I've rebooted the Mac and turned the printer off and on. I've double checked that I'm using the correct media and feed settings for the paper and I've double checked that the printer driver is up-to-date and have googled to see if I could find out what the problem/solution might be.

Can anyone help or point me in the right direction?

Many thanks in advance,
Richard

Discussion is locked
Follow
Reply to: Epson R3000 problem since 10.8.2 & iPhoto 9.4 update
PLEASE NOTE: Do not post advertisements, offensive materials, profanity, or personal attacks. Please remember to be considerate of other members. If you are new to the CNET Forums, please read our CNET Forums FAQ. All submitted content is subject to our Terms of Use.
Reporting: Epson R3000 problem since 10.8.2 & iPhoto 9.4 update
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Comments
- Collapse -
Clarification Request
Did you check the apple forum on this?
- Collapse -
I will do so

Thanks Bob, I shall read that thread and try this evening.

- Collapse -
Problem solved via Printing System Reset

For other non-tech users who might experience this one day (and it seems that lots do), I went to system preferences, print & scan, right clicked the printer and selected "reset the printing system". Once this was completed, I was able to add a printer, select from the list as my Mac detected the Epson, and all is well again.

Thanks again Bob for pointing me in the right direction, it saved me from a second evening of frustration.

Regards, Richard

- Collapse -
Thank you!

Thanks for distilling it down for the rest of us!
Bob

CNET Forums