and make sure that MAIL is set to be the default email reader on your machine.

It's a drop down on the first preferences tab, at the top.

P