Open up My Computer, and goto Tools > Folder Options, (or goto Control Panel > Folder Options),

Click the "View" tab, and scroll down to find "Hidden files and folders". Select "Show hidden files and folders"

Now, scroll down further to "Hide extensions for known file types", and de-select this if it is selected.

Finally, the line below, remove the tick, (de-select), the option for "Hide protected operating system files (Recommended)". You will get a warning message when you do that, just accept it, (click Yes).

Now open the folder you have on the Desktop and see if any files have appeared.

When you're done, return to Folder Options > View tab, and re-select the "Hide protected operating system files (Recommended)". The other options can be left as they are.

Mark