In Outlook, goto Tools > Options and click the Security tab.

In the Security area under Security Zones, click the "Zone Settings" button. you will be warned that you are about to change security settings for IE, Outlook and Outlook Express. Click OK, and this will bring you to the IE Security Settings options.

Highlight the IE globe and click Custom Level, and in the new window scroll down to Downloads > Automatic Prompting for file downloads. If that is set to DIsable, try changing it to Enable.

I hope this solves your problem.

Mark