Computer Help forum

Question

elantech touchpad works, but no clicking

by atlantisflygirl / October 14, 2011 11:55 AM PDT

I have a year old Asus with an Elantech smart touchpad run on windows vista (like the last update before windows 7). Sorry I don't have specifics, but I'm not great with keyboard input and couldn't get this info in my current situation!

I used my computer last night, no problems. I got home today and this is my problem:

My mouse seems to work. I have a pointer and I can move it via the touchpad. It wakes up the screensaver if I touch it. If I hover over something on the desktop or a window I've opened via keystrokes, it highlights as though it's clickable. The elantech icon on the menu bar shows that it's receiving input.

If I try to click something, however, either via the buttons below the touchpad or by double clicking the touchpad, nothing happens.

My computer updated its software a few days ago. I ran ccleaner and defragged about a week ago. I regularly run malwarebytes in addition to avg free scans. Using another computer for how to navigate windows without a mouse, I keyboarded my way through to the control panel and, from there, checked mouse settings. I rolled back driver updates and restarted. No joy. I reupdated the driver, restarted and still no joy. I shutdown, took out the battery and let it sit completely juice-less. You guessed it: no joy.

I'm not great with computers. I know enough to look at and do the things I did above, but maybe there are things I haven't thought of? Since the computer is acting normally in every other way, I'm inclined to believe that it's a mechanical issue with the buttons rather than SNAFU because of an electrical surge (we've had rain/thunderstorms all day).

Does anyone have any ideas or has anyone had a similar experience? I'm flummoxed. I don't have an external mouse, but one is coming to me on Sunday. My gut is that it will work, but I obviously can't say for sure right now.

I'd be happy for any ideas/input anyone has!

Thanks,
atlflygirl

Discussion is locked
You are posting a reply to: elantech touchpad works, but no clicking
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: elantech touchpad works, but no clicking
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.

All Answers

Collapse -
Answer
Try
by R. Proffitt Forum moderator / October 14, 2011 12:00 PM PDT

Try the Asus page on your machine and see if they have the Elan software for download then uninstall the old and install their newest.
Bob

Collapse -
Re: elantech touchpad works, but no clicking
by atlantisflygirl / October 14, 2011 12:51 PM PDT
In reply to: Try

Bob, thanks for the lead! I've been drowning my sorrows in martini, so I'll try it first thing in the morning! I'll continue to cry here if I've had no luck!

atlflygirl

Collapse -
This is a part 2 to this.
by R. Proffitt Forum moderator / October 14, 2011 12:55 PM PDT

After I do that step I scour the Elan controls for any setting I missed.

Popular Forums
icon
Computer Newbies 10,686 discussions
icon
Computer Help 54,365 discussions
icon
Laptops 21,181 discussions
icon
Networking & Wireless 16,313 discussions
icon
Phones 17,137 discussions
icon
Security 31,287 discussions
icon
TVs & Home Theaters 22,101 discussions
icon
Windows 7 8,164 discussions
icon
Windows 10 2,657 discussions

CNET FORUMS TOP DISCUSSION

Help, my PC with Windows 10 won't shut down properly

Since upgrading to Windows 10 my computer won't shut down properly. I use the menu button shutdown and the screen goes blank, but the system does not fully shut down. The only way to get it to shut down is to hold the physical power button down till it shuts down. Any suggestions?