Routers allow us to install older versions. You can try that next.